Bug 59829 - Quick Fix menu item doesn't show anything
Summary: Quick Fix menu item doesn't show anything
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: 6.3 (15.1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2017-09-28 17:36 UTC by Gary
Modified: 2017-10-03 06:08 UTC (History)
1 user (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Video of an Interface error (1.19 MB, video/mp4)
2017-09-28 17:37 UTC, Gary
Details
NSIndexPath error (1.78 MB, video/mp4)
2017-09-28 17:37 UTC, Gary
Details
The C# Edit button that I clicked to change my preferences (98.94 KB, image/png)
2017-09-28 17:39 UTC, Gary
Details

Description Gary 2017-09-28 17:36:16 UTC
I had an email exchange about this issue with Adam Hartley on 2-15-2017 and 2-17-2017 under the subject "Quick Fix doesn't do anything".  The problem is that right clicking in Xamarin Studio shows the Quick Fix menu item at the top of the popup menu but clicking that menu item doesn't show anything.  Please see the attached videos for two examples.  Adam had me uninstall Xamarin Studio on 2-15-2017 by running these commands in Terminal.

sudo rm -rf "/Applications/Xamarin Studio.app"
rm -rf ~/Library/Caches/XamarinStudio-*
rm -rf ~/Library/Preferences/XamarinStudio-*
rm -rf ~/Library/Logs/XamarinStudio-*
rm -rf ~/Library/XamarinStudio-*

After I ran these commands, the Quick Fix menu item worked as expected on 2-15-2017.  However, this caused me to lose all of my Xamarin Studio preferences so I started setting them up again.  I think the only things I changed were a few settings under Source Code --> C# Source Code --> C# Format --> Edit.  On 2-17-2017 the Quick Fix menu item stopped working again and I've been testing it every once in a while to see if someone else reported the problem to you.

I think it was my C# source code settings that caused the Quick Fix menu item to break so if you tell me where those settings are stored I will send them to you to see if you can replicate the problem.

=== Xamarin Studio Community ===

Version 6.3 (build 864)
Installation UUID: babd5947-50bf-4615-a075-ff442f7fd352
Runtime:
	Mono 5.2.0.224 (d15-3/14f2c81) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000224

=== NuGet ===

Version: 3.5.0.0

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: 7.4.5.1 (Xamarin Studio Community)
Android SDK: /Users/gem/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		6.0 (API level 23)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Inspector ===

Version: 1.3.1
Hash: cbc48dd
Branch: 1.3-release
Build date: Thu, 21 Sep 2017 19:52:53 GMT
Client compatibility: 1

=== Apple Developer Tools ===

Xcode 8.3.3 (12175.1)
Build 8E3004b

=== Xamarin.iOS ===

Version: 11.0.0.0 (Xamarin Studio Community)
Hash: 152b654a
Branch: xcode9
Build date: 2017-09-15 02:25:56-0400

=== Xamarin.Mac ===

Version: 3.6.3.3 (Xamarin Studio Community)

=== Build Information ===

Release ID: 603000864
Git revision: 6c2f6737278ccc3e81e12276d49c0d92f975f189
Build date: 2017-04-24 11:26:01-04
Xamarin addins: d8d46e577d8507c35260ce9d73df3c33415bb214
Build lane: monodevelop-lion-d15-1

=== Operating System ===

Mac OS X 10.12.6
Darwin iMac.local 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64
Comment 1 Gary 2017-09-28 17:37:15 UTC
Created attachment 25008 [details]
Video of an Interface error
Comment 2 Gary 2017-09-28 17:37:48 UTC
Created attachment 25009 [details]
NSIndexPath error
Comment 3 Gary 2017-09-28 17:39:59 UTC
Created attachment 25010 [details]
The C# Edit button that I clicked to change my preferences
Comment 4 Mike Krüger 2017-09-29 07:26:52 UTC
That's a very detailed bug report :).

The version you're using is fairly old - it should work on a 7.x more reliable.
Comment 5 Gary 2017-10-03 06:08:55 UTC
When I check for updates in Xamarin Studio Community it says that I'm up to date.  When is 7.x scheduled to be released?  I hope that this issue will actually be tested in 7.x rather than just expecting that it will work because you have improved the code in so many ways.

Note You need to log in before you can comment on or make changes to this bug.