Bug 59809 - I18NPortable Issue
Summary: I18NPortable Issue
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: XI 11.0 (xcode9)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-28 08:02 UTC by Shabeeb
Modified: 2017-11-07 06:10 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Shabeeb 2017-09-28 08:02:27 UTC
projectname.iOS/MTOUCH: Error MT2101: Can't resolve the reference 'I18NPortable.II18N I18NPortable.I18N::get_Current()', referenced from the method 'System.Void projectname.App::.ctor()' in 'I18NPortable, Version=0.6.0.0, Culture=neutral, PublicKeyToken=null'. (MT2101) (projectname.iOS)
Comment 1 Timothy Risi 2017-09-28 18:37:13 UTC
Please include your full build logs, crash reports (if any), test case (to reproduce) and all version information.

To get full build logs just set the log verbosity to diagnostic at the following locations:
- On Visual Studio for Mac: Preferences > Projects > Build
- On Visual Studio for Windows: Tools > Options > Projects and Solutions > Build and Run

On Visual Studio Windows you also want to add `-v -v -v -v` to the mtouch additional arguments by right-clicking the project in the solution explorer and selecting `Properties`.
Note: this is done automatically on Visual Studio for Mac when the log verbosity is set to diagnostic.

Easiest way to get exact version information:
- On Visual Studio for Mac: "Visual Studio" menu, "About Visual Studio" item, "Show Details" button.
- On Visual Studio for Windows: "Help menu", "About Microsoft Visual Studio" item.
Then copy/paste the version information (you can use the "Copy Information" button).
Comment 2 Shabeeb 2017-09-29 12:33:03 UTC
/Users/mohamedshabeeb/Projects/Zemose/packages/Microsoft.Bcl.Build.1.0.21/build/Microsoft.Bcl.Build.targets(243,5): warning : All projects referencing Zemose.csproj must install nuget package Microsoft.Bcl.Build. For more information, see http://go.microsoft.com/fwlink/?LinkID=317569.
/Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(2001,5): warning MSB3276: Found conflicts between different versions of the same dependent assembly. Please set the "AutoGenerateBindingRedirects" property to true in the project file. For more information, see http://go.microsoft.com/fwlink/?LinkId=294190.
/Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(2001,5): warning MSB3277: Found conflicts between different versions of the same dependent assembly that could not be resolved.  These reference conflicts are listed in the build log when log verbosity is set to detailed.
MTOUCH : warning MT0109: The assembly 'Google.Maps.dll' was loaded from a different path than the provided path (provided path: /Users/mohamedshabeeb/Projects/Zemose/packages/Xamarin.Google.iOS.Maps.2.1.0/lib/Xamarin.iOS10/Google.Maps.dll, actual path: /Users/mohamedshabeeb/Projects/Zemose/Zemose/Zemose.iOS/obj/iPhoneSimulator/Debug/XBDResourceMerge/Google.Maps.dll).
MTOUCH : error MT2101: Can't resolve the reference 'I18NPortable.II18N I18NPortable.I18N::get_Current()', referenced from the method 'System.Void Zemose.App::.ctor()' in 'I18NPortable, Version=0.6.0.0, Culture=neutral, PublicKeyToken=null'.
    4 Warning(s)
    1 Error(s)
Comment 3 Shabeeb 2017-09-29 12:34:09 UTC
=== Visual Studio Community 2017 for Mac ===

Version 7.1.5 (build 2)
Installation UUID: 6e359428-110d-465c-b94e-2ae120f83516
Runtime:
	Mono 5.2.0.224 (d15-3/14f2c81) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000224

=== NuGet ===

Version: 4.3.0.2418

=== .NET Core ===

Runtime: Not installed
SDK: Not installed
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: 11.0.0.0 (Visual Studio Community)
Hash: 152b654a
Branch: xcode9
Build date: 2017-09-15 02:25:56-0400

=== Xamarin.Android ===

Version: 7.4.5.1 (Visual Studio Community)
Android SDK: /Users/mohamedshabeeb/Documents/sdk
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)
		7.0    (API level 24)

SDK Tools Version: 26.1.1
SDK Platform Tools Version: 26.0.0
SDK Build Tools Version: 25.0.2

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Inspector ===

Version: 1.3.1
Hash: cbc48dd
Branch: 1.3-release
Build date: Thu, 21 Sep 2017 19:52:53 GMT
Client compatibility: 1

=== Xamarin.Mac ===

Version: 3.6.3.3 (Visual Studio Community)

=== Build Information ===

Release ID: 701050002
Git revision: 7afedcaef8e7542e70e3cf8f9bdb26938b8c0876
Build date: 2017-09-15 08:39:58-04
Xamarin addins: 3262aadf811a18c12eac6742532d052b0139a808
Build lane: monodevelop-lion-d15-3-xcode9

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Gorilla Player 1.0.0.15
Comment 4 Shabeeb 2017-10-03 05:48:16 UTC
Should I expect any update here?
Comment 5 Timothy Risi 2017-10-03 06:38:06 UTC
Can you provide the full build logs and a test project that demonstrates the issue?  I've been unable to reproduce it so far.
Comment 6 Alex Soto [MSFT] 2017-11-07 06:10:27 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!

Note You need to log in before you can comment on or make changes to this bug.