Bug 59803 - Toggling IsVisible on ListView
Summary: Toggling IsVisible on ListView
Status: VERIFIED DUPLICATE of bug 59720
Alias: None
Product: Windows iOS Simulator
Classification: Xamarin
Component: Simulator (show other bugs)
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-27 23:48 UTC by Lawrence
Modified: 2017-10-05 17:25 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Solution (222.57 KB, application/x-zip-compressed)
2017-09-27 23:48 UTC, Lawrence
Details

Description Lawrence 2017-09-27 23:48:35 UTC
Created attachment 24971 [details]
Solution

Overview:

Toggling the IsVisible on the ListView causes the layout to not render properly on iOS.  It will toggle properly on Android.

Steps to Reproduce:

1) Open up the attached solution

2) Start up the simulator for iOS and click on the "Toggle ListView" multiple times

The ListView will display sometimes other times not at all, the button will also have a weird style on it as if the InvalidateLayout is not properly redrawing the layout.  The ListView will sometimes not get hidden when it's supposed to be.

Expected Results: 
On the odd numbered clicks (1,3,5...), the ListView should display fully and push the button to the bottom.  On the clicks that are even (2,4,6...), the ListView should collapse fully and the button should be moved back to the top.

Build Date & Hardware: Date and hardware of the build in which you first encountered the bug.

Xamarin.Forms 2.4.0.280
Visual Studio Enterprise 2017 15.4.0 Preview 3.0
Xamarin 4.7.0.1001
Xamarin.Android SDK 8.0.0.21
Xamarin.iOS and Xamarin.Mac SDK 11.2.0.4

Additional Builds and Platforms:

Doesn't appear to happen in Android, only in iOS

Additional Information: Any other useful information. 
I have a screen capture (gif) of it happening: https://gifyu.com/image/MmuB
The 2 clicks of the button worked as expected then it all goes downhill from there.
Comment 1 Paul DiPietro [MSFT] 2017-09-28 00:51:32 UTC
This appears to be an issue with the Windows simulator, as the simulator running on the Mac works as expected. I'll reassign this to get some feedback.
Comment 2 Alan McGovern 2017-09-28 10:06:37 UTC
Paul, were you able to see it working correctly inside Apples simulator and failing inside the Remote simulator, or did you just try Apples simulator and assume it'd break in the windows sim?

It's unlikely to be an issue in the windows simulator based on the screencast, but if you confirmed that was actually the case we can look into it futher.
Comment 3 Lawrence 2017-09-28 12:20:03 UTC
I can confirm what Paul was saying, when I loaded up the same solution on the Mac it works as expected.  However, on the Windows simulator it doesn't behave as intended when connected to the same Mac as a remote Mac Agent.
Comment 4 Alan McGovern 2017-09-28 13:19:55 UTC
Ah perfect, thanks! That definitely rules out a forms issue then! This sounds like a duplicate of 59720 so i'll mark it as such. We're still trying to see what the actual issue is there.

*** This bug has been marked as a duplicate of bug 59720 ***
Comment 5 Alan McGovern 2017-10-03 12:56:56 UTC
The testcase was perfect, we have the issue fixed and verified. We'll ship the fix with a future release of the platform, I just don't know which release that will be as of yet.

Note You need to log in before you can comment on or make changes to this bug.