Bug 59685 - Status Bar pushing down UITableViewController
Summary: Status Bar pushing down UITableViewController
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 11.0 (xcode9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-22 10:30 UTC by Ale
Modified: 2017-10-23 17:28 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
UIView control outline (49.15 KB, image/png)
2017-09-22 10:30 UTC, Ale
Details

Description Ale 2017-09-22 10:30:13 UTC
Created attachment 24883 [details]
UIView control outline

Since updating to Xamarin.iOS 11 the status bar on my UITableViewControllers is pushing down the view. Its particularly noticeable in the attached image (ZYuwH.png)

Before updating, the view extended under the status bar, you can see the original location with the ImageView outline. The same occurs once built and running on the device - A white status bar at the top of the view.

Steps to reproduce your issue. Create new a tableviewcontroller in storyboard and add some controls in the tableview's cell. The outlines is not at the same position as the controls.
Comment 1 Manuel de la Peña 2017-09-22 14:34:29 UTC
Hello,

We need to see if this is an issue with our bindings our a change in Apples side. Can you please:

1. Provide the environment information of the system you are using to build the app.
2. Provide a small sample application that we can use to test the behaviour in previous releases and ensure that this is not a regression.
Comment 2 Timothy Risi 2017-10-23 17:28:11 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!

Note You need to log in before you can comment on or make changes to this bug.