Bug 59643 - Trigger does not return default value with using TemplateBinding
Summary: Trigger does not return default value with using TemplateBinding
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-21 12:44 UTC by Ruslan Zakharov
Modified: 2017-11-07 15:53 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Ruslan Zakharov 2017-09-21 12:44:04 UTC
# Steps to reproduce
1) Create code in XAML:
    <Grid BackgroundColor="#4C000000">
        <Grid.Triggers>
            <Trigger TargetType="Grid" Property="IsVisible" Value="False">
                <Setter Property="BackgroundColor" Value="{TemplateBinding MyColor}" />
            </Trigger>
        </Grid.Triggers>
    </Grid>
2) Create MyColor bindable property in code behind;
3) Change IsVisible property from True to False and vice versa.

# Expected behavior
Grid should be changed to MyColor color when IsVisible=False, and to default state (#4C000000) when IsVisible=True

# Actual behavior
Grid is not changed to default state (#4C000000) when IsVisible=True

# Supplemental info (logs, images, videos)
None

# Test environment (full version information)
IDE - Visual Studio 2017
Xamarin.Forms - 2.3.5.233
Comment 1 Paul DiPietro [MSFT] 2017-09-29 18:51:29 UTC
Are you still experiencing this issue with the 2.4.0 stable release?
Comment 2 Ruslan Zakharov 2017-10-04 07:11:54 UTC
Hello Paul,
I will update to new version later and let you know
Comment 3 Paul DiPietro [MSFT] 2017-11-06 21:34:28 UTC
As we have not heard back in over a month we will be closing this issue. Please reopen with a reproduction project to aid investigation if the issue is still occurring as of the latest stable build of Forms. Thanks!
Comment 4 Ruslan Zakharov 2017-11-07 15:53:07 UTC
Okay, I will verified it after installation new version, currently our team use older version.