Bug 59632 - Unable to create IBOutlet by drag and drop
Summary: Unable to create IBOutlet by drag and drop
Status: RESOLVED DUPLICATE of bug 58198
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 11.0 (xcode9)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-21 07:32 UTC by Christophe C
Modified: 2017-09-21 13:24 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 58198

Description Christophe C 2017-09-21 07:32:57 UTC
Hello, 

I noticed a bug in the last stable version of Visual Studio for Mac (not tested on Windows) and the last version of Xamarin.iOS.
When I create a sample Xamarin project, add a view controller then open Xcode to link some controls to my view controller, I can not link any controls. 

"When selecting a ViewController in a storyboard, the assistant editor set to Automatic yields "No Assistant Results", and manually choosing the header file doesn't allow adding outlets with the following error message in a bubble: "Could not insert new outlet connection: Could not find any information for the class named [ViewControllerNameHere]"

As a work-around, it's possible to enter the outlet in code manually, and then just drag the line from your control to that piece of code. So it can't generate the outlet in code for you (anymore), but luckily, you can still do it manually."

Here is a discussion in the Xamarin Forum : https://forums.xamarin.com/discussion/99772/web-preview-xamarin-ios-10-99-preview-9-for-ios-11-tvos-11-and-watchos-4-sdk-bindings?

Thank you for the fix ;)

Here is some informations about my Visual Studio :

=== Visual Studio Community 2017 for Mac ===

Version 7.1.5 (build 2)
Installation UUID: 9a1cb6a6-0fd6-40ab-a519-eaf8367e9946
Runtime:
	Mono 5.2.0.224 (d15-3/14f2c81) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000224

=== NuGet ===

Version: 4.3.0.2418

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
	1.1.2
	1.1.1
	1.0.5
	1.0.4
SDK: /usr/local/share/dotnet/sdk/2.1.0-preview1-006329/Sdks
SDK Versions:
	2.1.0-preview1-006329
	1.0.4
	1.0.3
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: 7.4.5.1 (Visual Studio Community)
Android SDK: /Users/Christophe/Library/Android/sdk
	Supported Android versions:
		4.1 (API level 16)
		6.0 (API level 23)
		7.0 (API level 24)
		7.1 (API level 25)

SDK Tools Version: 26.0.2
SDK Platform Tools Version: 26.0.0
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Inspector ===

Version: 1.3.0
Hash: 8c298a5
Branch: 1.3-release
Build date: Thu, 14 Sep 2017 21:21:26 GMT
Client compatibility: 1

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: 11.0.0.0 (Visual Studio Community)
Hash: 152b654a
Branch: xcode9
Build date: 2017-09-15 02:25:56-0400

=== Xamarin.Mac ===

Version: 3.6.3.3 (Visual Studio Community)

=== Build Information ===

Release ID: 701050002
Git revision: 7afedcaef8e7542e70e3cf8f9bdb26938b8c0876
Build date: 2017-09-15 08:39:58-04
Xamarin addins: 3262aadf811a18c12eac6742532d052b0139a808
Build lane: monodevelop-lion-d15-3-xcode9

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Android Signature Tool 2.1.2
AddinMaker 1.3.7
NuGet Package Explorer 0.2
Redth's Addins 1.0.9
Manifest.addin 0.0.0.0
Comment 1 Sebastien Pouliot 2017-09-21 13:24:12 UTC

*** This bug has been marked as a duplicate of bug 58198 ***