Bug 59607 - LLVM breaks Expressions in IQueryable<T> Where method (device only)
Summary: LLVM breaks Expressions in IQueryable<T> Where method (device only)
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler (show other bugs)
Version: XI 11.0 (xcode9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2017-09-20 15:00 UTC by Colby Williams
Modified: 2017-11-02 23:10 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Comment 1 Zoltan Varga 2017-09-20 15:25:38 UTC
I can reproduce with the attached project.
Comment 2 Zoltan Varga 2017-09-20 15:42:23 UTC
Seems somewhat random, can't reproduce it anymore.
Comment 3 Colby Williams 2017-09-20 15:44:44 UTC
Manually delete the bin/obj folders and make sure you're building for Release|iPhone with LLVM enabled
Comment 4 Zoltan Varga 2017-09-20 15:53:37 UTC
Can anybody else reproduce this ?
Comment 5 Sebastien Pouliot 2017-09-27 15:36:04 UTC
It works fine with master

=== Visual Studio Enterprise 2017 for Mac ===

Version 7.1.5 (build 2)
Installation UUID: f3e082fd-6d82-4b83-8c52-de2e679a624a
Runtime:
	Mono 5.4.0.174 (2017-06/1afb931de69) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 504000174

=== NuGet ===

Version: 4.3.0.2418

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Version: 2.0.0
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Version: 2.0.0
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: 11.5.0.31 (Visual Studio Enterprise)
Hash: 50148e7c
Branch: master
Build date: 2017-09-26 15:36:40-0400

=== Xamarin.Android ===

Version: 7.4.0.21 (Visual Studio Enterprise)
Android SDK: /Users/poupou/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		6.0 (API level 23)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Inspector ===

Version: 1.3.0
Hash: 8c298a5
Branch: 1.3-release
Build date: Thu, 14 Sep 2017 21:21:26 GMT
Client compatibility: 1

=== Xamarin.Mac ===

Version: 4.1.0.102 (Visual Studio Enterprise)

=== Build Information ===

Release ID: 701050002
Git revision: 7afedcaef8e7542e70e3cf8f9bdb26938b8c0876
Build date: 2017-09-15 08:39:58-04
Xamarin addins: 3262aadf811a18c12eac6742532d052b0139a808
Build lane: monodevelop-lion-d15-3-xcode9

=== Operating System ===

Mac OS X 10.13.0
Darwin 17.0.0 Darwin Kernel Version 17.0.0
    Thu Aug 24 21:48:19 PDT 2017
    root:xnu-4570.1.46~2/RELEASE_X86_64 x86_64


@Colby is that always happening to you ? or is it random ? (like Zoltan was guessing in comment #2)
Comment 6 Vincent Dondain [MSFT] 2017-11-02 23:10:52 UTC
I can't reproduce either with current stable: https://gist.github.com/VincentDondain/56a164233f5a4f3e90dbd7f2deaa95e2

Closing this issue as no one seem to be able to reproduce it and @colby did not provide extra information (: