Bug 59527 - xamarin.forms button properties BorderRadius and BorderWidth value does not matter on android
Summary: xamarin.forms button properties BorderRadius and BorderWidth value does not m...
Status: RESOLVED DUPLICATE of bug 36031
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.4.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-15 18:45 UTC by Roman
Modified: 2017-10-31 16:51 UTC (History)
4 users (show)

Tags: appcompat, button, borderradius, ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 36031

Description Roman 2017-09-15 18:45:49 UTC
I've noticed that Xamarin.Forms Button properties BorderRadius and BorderWidth value on android does not matter but on iOS all works good. 
I've noticed this in XAML and don`t try repeat this in cs
Comment 1 Paul DiPietro [MSFT] 2017-09-18 17:04:45 UTC
I will leave this as confirmed for now, but I believe there may have been a reason for that behavior.
Comment 2 Roman 2017-10-02 19:43:56 UTC
This problem stayed in 2.4 version partially.

If I use XAML with style:

<Style x:Key="buttonStyle" TargetType="Button">
                <Setter Property="BorderRadius" Value="25" />
                <Setter Property="BackgroundColor" Value="Blue" />
                <Setter Property="BorderColor" Value="Red" />
                <Setter Property="BorderWidth" Value="3" />
                <Setter Property="TextColor" Value="White" />
                <Setter Property="Margin" Value="0, 10"/>
            </Style>

that all work fine

But if use XAML with set parameters immediately:

<Button x:Name="_butLogin" IsEnabled="False" Font="Medium" Text="{local:TranslateExtension enter}" Clicked="Button_Clicked" HorizontalOptions="Center"
                        Margin="20" BorderRadius="25"/>

Or in cs code:

 Button butShow = new Button();
            butShow.Text = Resource.show;
            butShow.BorderRadius = 20; 

That it does not work yet
Comment 3 Samantha Houts [MSFT] 2017-10-31 16:51:30 UTC

*** This bug has been marked as a duplicate of bug 36031 ***