Bug 59515 - App Store iOS icon missing
Summary: App Store iOS icon missing
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: unspecified
Hardware: PC Windows
: High normal
Target Milestone: xcode9
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2017-09-15 12:06 UTC by Paolo Brocco
Modified: 2018-04-20 12:42 UTC (History)
11 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Paolo Brocco 2017-09-15 12:06:18 UTC
I just tried to make a release for iOS 11.

I installed (necessary to build my project):
- XCode 9 GM
- xamarin ios and xamarin mac on top of the last stable packages already present in my system from https://jenkins.mono-project.com/view/Xamarin.MaciOS/job/xamarin-macios-builds-xcode9/

I could make a release with Visual Studio for Mac, archive for publishing and upload it via application loader.

After a few minutes I received this e-mail from itunesconnect:

"Missing Marketing Icon - iOS Apps must include a 1024x1024px Marketing Icon in PNG format. Apps that do not include the Marketing Icon cannot be submitted for App Review or Beta App Review. 

After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect."

Please see ErAcube answer and firepol comments on https://stackoverflow.com/questions/46216718/missing-cfbundleiconname-in-xcode9-ios11-app-release

The Visual Studio UI doesn't show an entry for the app store icon, nor does Visual Studio for Mac. But XCode does.

You need to fix this and allow the user to add also the app store icon, which seems required now. You even documented that it's required, see under "Store Icon": https://developer.xamarin.com/guides/ios/platform_features/introduction-to-ios11/updating-your-app/

Thanks and best regards
Comment 1 Jeffrey Stedfast 2017-09-18 15:18:58 UTC
I'm pretty sure this is already in the 15.3 release (might not have gone to Stable yet, not sure).

Either way, this has already been fixed. I fixed it a few weeks ago :)
Comment 2 Gilbok Lee 2017-09-22 14:09:59 UTC
You can set your 1024 store icon in AppIcon under Assets.xcassets.
I already tested it on the latest Xamarin.iOS and Xcode 9(for iOS 11)
Comment 3 KKelaiya 2017-09-25 02:52:01 UTC
I have following setup:
- Xamarin Studio Community Version 6.3 (build 864) 
- Xamarin.iOS Version: 11.0.0.0 -- Build date: 2017-09-15 02:25:56-0400
- Xcode Version 9.0 (9A235)

There is no stable update at a moment on top of above. 

In this setup, I am not seeing "1024 store icon" in Assets.xcassets. There is Mac 2x which is 1024 and in info.plist, there is iTunes Artwork which is also 1024. 
However even after updating both, I am still getting following once binary is uploaded.

WARNING ITMS-90704: "Missing Marketing Icon. iOS Apps must include a 1024x1024px Marketing Icon in PNG format. Apps that do not include the Marketing Icon cannot be submitted for App Review or Beta App Review."

What would be workaround considering future compatibility?

Thanks
Comment 4 Andrew 2017-10-03 19:18:08 UTC
@Gilbok Lee - can you explain what version of Xamarin Studio are you using to see the fix?

Like @KKelaiya I'm facing the same issue.

I've manually edited the Contents.json file in the AppIcons.appiconset folder with the following

    {
      "size" : "1024x1024",
      "idiom" : "ios-marketing",
      "filename" : "app-icon-radial-store-fulfillment@1024.png",
      "scale" : "1x"
    },

and I'm still presented with the same Warning from Apple.


=== Xamarin Studio Community ===

Version 6.3 (build 864)
Installation UUID: a7ab0afe-2dd0-4bae-970d-70e449dd90b3
Runtime:
	Mono 5.2.0.224 (d15-3/14f2c81) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000224

=== NuGet ===

Version: 3.5.0.0

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.Mac ===

Version: 3.6.3.3 (Xamarin Studio Community)

=== Xamarin.iOS ===

Version: 11.0.0.0 (Xamarin Studio Community)
Hash: 152b654a
Branch: xcode9
Build date: 2017-09-15 02:25:56-0400

=== Xamarin.Android ===

Not Installed

=== Xamarin Inspector ===

Version: 1.3.1
Hash: cbc48dd
Branch: 1.3-release
Build date: Thu, 21 Sep 2017 19:52:53 GMT
Client compatibility: 1

=== Build Information ===

Release ID: 603000864
Git revision: 6c2f6737278ccc3e81e12276d49c0d92f975f189
Build date: 2017-04-24 11:26:01-04
Xamarin addins: d8d46e577d8507c35260ce9d73df3c33415bb214
Build lane: monodevelop-lion-d15-1

=== Operating System ===

Mac OS X 10.12.6
Darwin VendorNets-MacBook-Air-2.local 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2017-10-17 22:47:11 UTC
> Xamarin Studio

For the users in Comment 3 and Comment 4, note that IDE compatibility with Xcode 9 requires Visual Studio for Mac.  Xamarin Studio development concluded with version Xamarin Studio 6.3 [1], and that version was released before the first Xcode 9 previews from Apple.

[1] https://developer.xamarin.com/releases/studio/xamarin.studio_6.3/xamarin.studio_6.3/

> Xamarin Studio 6.3 is the final release of Xamarin Studio. We recommend that
> developers now use Visual Studio on both Windows and Mac. Visual Studio for
> Mac has all the features of Xamarin Studio, adds cloud and web development,
> and contains improvements for cross-platform mobile development.
Comment 6 Samiya A 2017-11-14 19:53:51 UTC
I'm having the exact same issue as KKelaiya mentioned above. I've also tried Visual studio for Mac but I get the same error from Apple. I've added the marketing icon in Contents.json as well. Please advise, we've been trying to release an urgent fix to production but are held back due to all these issues.
Comment 7 Andrew 2017-11-14 21:36:53 UTC
@Samiya -

Maybe this can help. It does work for Visual Studio for the Mac. But before that, I'd also updated the contents.json and also included the image. However, what I failed to noticed and/or realize my image had some transparent pixels and that was also causing the failure for the app to be accepted.

Also, you can try to upload the marketing image in iTunes to help validate that the image is the correct size and there's no transparent pixel in the image.

It's frustrating.. but I hope this helps you a little.
Comment 8 ScottRFrost 2017-11-17 16:30:56 UTC
I don't believe this issue should be in status resolved fixed.  I'm getting the same problem.

In info.plist on the visual assets tab, I have png images assigned to 512 x 512 and 1024 x 1024, but I still get the warning when submitting.

In addition, I receive this email:

Dear developer,

We have discovered one or more issues with your recent delivery for "APP NAME HERE". Your delivery was successful, but you may wish to correct the following issues in your next delivery:

Missing App Store Icon - iOS Apps must include a 1024x1024px App Store Icon in PNG format. Without providing the icon in the Asset Catalog or via iTunes Connect, apps cannot be submitted for App Review or Beta App Review. Refer to https://developer.apple.com/ios/human-interface-guidelines/icons-and-images/app-icon/ for more information.

After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect


I'm using latest VS 2017 on Windows 10 and fully up to date VS for Mac on the build "server".  No updates available in Visual Studio Installer on Windows or Menu > Check for updates... in Visual Studio for Mac.
Comment 9 Brendan Zagaeski (Xamarin Team, assistant) 2017-11-17 19:36:06 UTC
> I'm using latest VS 2017 on Windows 10

Thanks for the information about a potential related issue.  The specific problem tracked by this bug was the issue where the UI for the asset catalog editor did not have entries for the App Store icons (from Comment 0):

> The Visual Studio UI doesn't show an entry for the app store icon, nor
> does Visual Studio for Mac. But XCode does.

If you are seeing an issue when building from Windows where images that are successfully assigned within an asset catalog are not appearing in the final built Archive or .ipa file, the best next step would be to list the steps you are following and actual vs. expected results (ideally attaching a test case or diagnostic MSBuild logs if applicable) in a new issue via "Help > Send Feedback > Report a Problem" in Visual Studio 2017.  You can then follow the issue on https://developercommunity.visualstudio.com/.  Thanks again!
Comment 10 Andrew 2017-11-17 21:35:16 UTC
@Brendan is correct.. I don't see it on VS 2017 on Windows 10. I see it for VS for the Mac.  And due to the inconsistencies between the two. I'm force to do most of the Dev on the PC and then move to the Mac for the final touches.

so yeah.. you may have to file an issue for it.
Comment 11 paul.zolnierczyk@iinteractive.com 2018-04-20 12:42:21 UTC
I'm still getting this bug, each build I submit to the App Store generates this warning email from Apple.  I'm on the latest stable VS for Mac.  This project I'm working on is a multi-year project that started in 2015, is it possible some artifact from years of this project are causing this to not make it into the build archive I submit to Apple?  I can verify that the 1024pt App Store icon is in my Images.xcassets however on submit to Apple the warning is there.  My workaround is to manually upload the App Store icon to iTunes Connect but it's annoying to get that warning on each submission along with the email that comes along with it.

Note You need to log in before you can comment on or make changes to this bug.