Bug 5947 - xbuild cannot parse some mcs errors, shows "Compiler crashed"
Summary: xbuild cannot parse some mcs errors, shows "Compiler crashed"
Status: RESOLVED DUPLICATE of bug 14767
Alias: None
Product: Tools
Classification: Mono
Component: xbuild (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-07-02 13:05 UTC by Mikayla Hutchinson [MSFT]
Modified: 2014-02-10 10:56 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14767

Description Mikayla Hutchinson [MSFT] 2012-07-02 13:05:59 UTC
xbuild does not parse the following errors, so if there are no other errors it shows a "Compiler crashed" message instead because of the exit code.

		MonoDevelop.Core.Assemblies/MsNetFrameworkBackend.cs(63,25): error CS0152: The label `case 4.0:' already occurs in this switch statement
		MonoDevelop.Core.Assemblies/MsNetFrameworkBackend.cs(60,25): (Location of the symbol related to previous error)
		Tool /Library/Frameworks/Mono.framework/Versions/2.10.9/bin/dmcs execution finished.
/Library/Frameworks/Mono.framework/Versions/2.10.9/lib/mono/4.0/Microsoft.CSharp.targets: error : Compiler crashed with code: 1.
	Task "Csc" execution -- FAILED
	Done building target "CoreCompile" in project "/Users/michael/Mono/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core.csproj".-- FAILED
Comment 1 alex.escott 2014-02-07 23:46:55 UTC
Came across the same thing on Mac OS X 10.9.1, Xamarin version:

Version 4.2.2 (build 2)
Installation UUID: 75bf4db5-2bd9-4a54-8abe-27117258f643
Runtime:
	Mono 3.2.6 ((no/9b58377)
	GTK+ 2.24.23 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302060000
Comment 2 Jonathan Pryor 2014-02-10 10:56:59 UTC

*** This bug has been marked as a duplicate of bug 14767 ***