Bug 59394 - MissingMethodException when accessing IsTransient property on an object of type Exception.
Summary: MissingMethodException when accessing IsTransient property on an object of ty...
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-11 16:30 UTC by murat
Modified: 2017-12-04 16:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Codebehind for the MainPage class in a default Xamarin.Forms PCL project (1.26 KB, text/plain)
2017-09-14 16:04 UTC, murat
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description murat 2017-09-11 16:30:29 UTC
Happens on Xamarin.Forms v2.3.4.270 when executing the statement obj.GetType().GetRuntimeProperties().Select(prop => prop.GetValue(obj))) where obj is an Exception object. When the variable prop contains information about IsTransient property, GetValue() throws a MissingMethodException on Android. There's no such problem in iOS or UWP project.
Comment 1 murat 2017-09-11 16:36:05 UTC
Tried downgrading a few versions. Still happens in v2.3.3.193.
Comment 2 Jimmy [MSFT] 2017-09-12 16:31:58 UTC
I'm wondering if this is actually an issue with the Xamarin.Android API instead of Xamarin.Forms since it does not happen with the other platforms. 

Can you attach a minimal project that reproduces the crash so we can investigate further? When providing the project, please set the report's status back to NEW otherwise we may close this issue after a period no response. Thanks!
Comment 3 murat 2017-09-14 16:04:46 UTC
Created attachment 24751 [details]
Codebehind for the MainPage class in a default Xamarin.Forms PCL project
Comment 4 murat 2017-09-14 16:06:24 UTC
Code added.
Comment 5 Paul DiPietro [MSFT] 2017-09-19 19:57:55 UTC
Using that code, it appears that exception is raised on both iOS as well as Android on my machine. UWP does not hit it in this case. Could you provide more info on the version(s) of Android where the issue doesn't occur for you, as well as some of your version information? I do agree with Jimmy that it's possible (if not likely) that this is not specifically a Forms issue.
Comment 6 murat 2017-10-03 17:28:23 UTC
I mainly use a Samsung Galaxy S6 with Android 7.0 for testing, which throws the exception when running this code. I haven't tested other Android devices/versions.
Comment 7 Paul DiPietro [MSFT] 2017-12-04 16:27:34 UTC
As no further reports on this have been made for some time we are led to believe that this not specifically a Forms issue. If there is a reproduction which can be made that more clearly illustrates a Forms-specific issue, please reopen this with one, assuming the problem occurs as of the latest 2.5.0 stable release (as well as an updated VS). I might also suggest raising a Xamarin.Android issue per comment #2, in such a case.

Guidelines for creating reproductions are available at:
https://github.com/xamarin/Xamarin.Forms/wiki/Submitting-Bug-Reports