Bug 59299 - Android SDK is not reflected as an individual component in Willow, even though it is installed.
Summary: Android SDK is not reflected as an individual component in Willow, even thoug...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- critical
Target Milestone: 15.5
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-09-07 16:08 UTC by Gaurav Ganorkar
Modified: 2017-10-30 06:44 UTC (History)
7 users (show)

Tags: Globallogic
Is this bug a regression?: Yes
Last known good build:


Attachments
Set up logs (868.04 KB, application/x-zip-compressed)
2017-09-07 16:08 UTC, Gaurav Ganorkar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Gaurav Ganorkar 2017-09-07 16:08:16 UTC
Created attachment 24626 [details]
Set up logs

Description
-After upgrading to D15Rel-PR.2017.9.6.11, Android SDK 25 version is not reflected in Willow individual component.
-When Launched VS and Opened SDK manager , We are able to see all API 25 components.

Build info
-Baseline build \\cpvsbuild\Drops\VS\d15rel\products\26830.00
-Updated to Build \\cpvsbuild\drops\setuppr\D15Rel-PR\D15Rel-PR.2017.9.6.11

Steps to Reproduce
1-Install the baseline build first from \\cpvsbuild\Drops\VS\d15rel\products\26830.00
2-After finishing the installation Verify Android 23 API version is displayed in Individual Component.
3-Now upgrade VS from the build \\cpvsbuild\drops\setuppr\D15Rel-PR\D15Rel-PR.2017.9.6.11
4-After finishing installation , Click on Modify
5-Observe the individual Component with respect to Android 25 API version

Actual
-Android 25 components are not reflected in Willow individual components while when launched VS and Openend SDK manager,Android 23 and Android 25 components are reflected properly as well as working properly and Are downloaded through willow

Expected
-Willow should display android 25 version in willow individual components when its already installed.

Screencast link
-https://www.screencast.com/t/mDzTMd6Pmwg

Reproducible
-100%

Note
-Logs are attached
Comment 1 Luis Aguilera 2017-09-19 13:09:27 UTC
fixed in https://devdiv.visualstudio.com/DevDiv/XamarinVS/_git/VS/pullrequest/83500?_a=overview should be tested with the most recent VS d15rel build.
Comment 2 Mohak Barokar 2017-09-22 11:42:51 UTC
This bug is still reproducible with latest VS d15rel build, Following is the build config:

Builds Taken from:

Baseline build : \\cpvsbuild\Drops\VS\d15rel\products\26830.00

For Upgrade:

d15rel Build :\\cpvsbuild\Drops\VS\d15rel\products\26921.00

d15rel Build Gist: https://gist.github.com/mohakbarokar/439782e1cccc14ff1fb523dbf8a609fa

Screencast Link: https://www.screencast.com/t/K1RSbWDMne

Reopening this bug as the issue is still observed.
Comment 3 Luis Aguilera 2017-09-22 19:23:53 UTC
as described in https://bugzilla.xamarin.com/show_bug.cgi?id=59241#c3 Android 25 is installed in an upgrade scenario. However, there's a willow bug where "this component is installed but not checked off in individual components". Based on this, I'm dropping the severity to normal and moving to 15.5. We'll track down the devdiv bug and eventually mark this as an upstream issue.
Comment 4 Pierce Boggan [MSFT] 2017-10-13 01:54:26 UTC
Spoke with Joseph today. The plan is to make this an optional component in Willow again.
Comment 5 Pierce Boggan [MSFT] 2017-10-19 18:11:26 UTC
We made this a Recommended component that can be unchecked. The insertion for that has been merged. Marking as Resolved -> Fixed.
Comment 6 Gaurav Ganorkar 2017-10-30 06:44:04 UTC
The Recommended component changes have verified successfully under the Trello card "https://trello.com/c/UmhOmcYr/40-willow-25-recommended-component-fix"

Following is the status of testing:

PR Build Taken From: \cpvsbuild\drops\setuppr\D15Rel-PR\D15Rel-PR.2017.10.17.39\drop

Val Build Taken From: \cpvsbuild\drops\VS-Val\d15rel\products\27016.9000.vyedin.171016.092608\channels\internal\Release\bootstrappers\fixed\Enterprise

Baseline Build taken From: 15_4 Stable (Market)

Build Gist : https://gist.github.com/anonymous/d9bea7825f120e1e6c369e31a58e8be7

Verified Below scenarios:

1.Checked in Willow when we Uncheck the Android SDK 25 , Google Emulator (API 25) Gets Deselected
2.Checked scenario where both Android SDK 25 and Google Emulator are selected
3.Upgrade scenario From D15-4 stable market build to VAL build given above - As expected there were no change in SDK components and Successfully able to see the UPDATE button
4.Checked when individual component Android SDK 25 and Google emulator

No issue's are observed Hence marking this as Verified Fixed