Bug 59296 - [coreimage] Some `kCI*`keys are not bound
Summary: [coreimage] Some `kCI*`keys are not bound
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 10.99 (xcode9)
Hardware: PC Mac OS
: Normal enhancement
Target Milestone: xcode9.2
Assignee: Vincent Dondain [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-09-07 15:09 UTC by Sebastien Pouliot
Modified: 2017-11-20 14:06 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastien Pouliot 2017-09-07 15:09:24 UTC
Some are bound and not exposed due to the lack of documentation (about the type to be used in the NSDictionary).

Other needs to be verified and added to the right strong dictionaries where applicable

!missing-field! kCIImageApplyOrientationProperty not bound
!missing-field! kCIImageAuxiliaryDepth not bound
!missing-field! kCIImageAuxiliaryDisparity not bound
!missing-field! kCIImageNearestSampling not bound
!missing-field! kCIInputDepthImageKey not bound
!missing-field! kCIInputDisparityImageKey not bound
Comment 2 Vincent Dondain [MSFT] 2017-11-16 21:42:52 UTC
https://github.com/xamarin/xamarin-macios/pull/3017
Comment 3 Sebastien Pouliot 2017-11-20 14:06:47 UTC
Merged in xcode9.2 with https://github.com/xamarin/xamarin-macios/commit/f307f377a19d30d7cbac05478e37dd4d81350741