Bug 59141 - Designer says 'Error while creating this entry for Hugging and Compression properties
Summary: Designer says 'Error while creating this entry for Hugging and Compression pr...
Status: RESOLVED DUPLICATE of bug 58919
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-31 10:50 UTC by Paul Sinnema
Modified: 2017-11-02 15:01 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Image showing the messages in the property window (31.59 KB, image/png)
2017-08-31 10:50 UTC, Paul Sinnema
Details
screenshot (86.76 KB, image/jpeg)
2017-11-02 14:00 UTC, Michael Shapiro
Details
log file (3.26 MB, application/x-zip-compressed)
2017-11-02 14:02 UTC, Michael Shapiro
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 58919

Description Paul Sinnema 2017-08-31 10:50:24 UTC
Created attachment 24498 [details]
Image showing the messages in the property window

I can not set the Hugging and Compression properties via the Designer because it says 'Error while creating this entry'.

Version info:

Microsoft Visual Studio Professional 2017 
Version 15.3.3
VisualStudio.15.Release/15.3.3+26730.12
Microsoft .NET Framework
Version 4.7.02046

Xamarin   4.6.0.299 (b63523e27)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.4.0.21 (2851083)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.12.0.20 (80b8487)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 1 Prashant [MSFT] 2017-09-01 06:22:11 UTC
Thanks so much for taking the time to submit this report! 

In order to investigate the issue further. 
Please attach the following to help us reproduce this issue: 
-Detailed reproduction steps 
-Version information (Help → About Microsoft Visual Studio → Copy Info) 
-Logs (Help → Xamarin → Zip Logs (last 7 days)) 
-Optional: project to reproduce your issue
Comment 2 Pierce Boggan [MSFT] 2017-10-03 16:37:11 UTC
Because we have not received a reply to our request for more information in over 4 weeks, we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information so we can continue looking into this. Thanks!
Comment 3 Pierce Boggan [MSFT] 2017-10-03 16:37:26 UTC
Because we have not received a reply to our request for more information in over 4 weeks, we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information so we can continue looking into this. Thanks!
Comment 4 Michael Shapiro 2017-11-02 13:58:12 UTC
Please reopen. This issue is real and still present.

Environment:

Windows 10 Pro
Microsoft Visual Studio Professional 2017 Version 15.4.2
Mono Debugging for Visual Studio   4.7.4-pre (c2d89eb)
Xamarin   4.7.10.33 (70936af)
Xamarin.Android SDK   8.0.2.1 (HEAD/c2a33d8ea)
Xamarin.iOS and Xamarin.Mac SDK   11.2.1.0 (12e80e0)


Problem:

In iOS storyboard it is impossible to edit/view Constraints' Hugging and Resistance priorities. 


Repro:
1) Create Xamarin iOS project
2) Open storyboard
3) Place any View on the Scene.
4) Select a View
5) Look at the Property page of the selected View
6) Go to Properties' Layout tab
7) Observe the Hugging and Resistance priority display red error message "Error while creating this entry" 

Attachments:
1) screenshot
2) Xamarin logs (7 days)
Comment 5 Michael Shapiro 2017-11-02 14:00:33 UTC
Created attachment 25542 [details]
screenshot
Comment 6 Michael Shapiro 2017-11-02 14:02:17 UTC
Created attachment 25543 [details]
log file
Comment 7 Alan McGovern 2017-11-02 14:54:15 UTC
This was fixed by https://github.com/xamarin/designer/commit/4a334700cf7778055935c9f450cbaabce9b6d96e which landed several months ago. This should already be shipping as part of the 15.5 release cycle, which means things should work with the latest Visual Studio preview release.

*** This bug has been marked as a duplicate of bug 58919 ***
Comment 9 Michael Shapiro 2017-11-02 15:01:54 UTC
Thanks for the info. Will wait when 15.5 is available then.