Bug 59136 - Selector name found in current argument registers: configureAnimation:forLayer:forKey:
Summary: Selector name found in current argument registers: configureAnimation:forLaye...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.4
Hardware: PC Windows
: Normal major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-31 08:46 UTC by Philipp Sumi
Modified: 2017-10-06 17:54 UTC (History)
2 users (show)

Tags: hockeyapp, crash
Is this bug a regression?: ---
Last known good build:


Attachments
HockeyApp crash log (67.65 KB, text/plain)
2017-08-31 08:46 UTC, Philipp Sumi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Philipp Sumi 2017-08-31 08:46:29 UTC
Created attachment 24495 [details]
HockeyApp crash log

I'm seeing a lot of hard crashes on this one in HockeyApp, and occasionally caused this myself. Not idea why, I don't even have animations running on the page I encountered this - maybe there was a progress spinner. I've attached the HockeyApp crash log, maybe it'll help.

There's also a forum entry on this one with different users seeing this happening in different scenarios - see here: 
https://forums.xamarin.com/discussion/99034/xamarin-forms-ios-error-selector-name-found-in-current-argument-registers-configureanimation-forlay

I've never seen this before, this could have been introduced with one of the more recent stable releases.

Thanks,
Philipp
Comment 1 Paul DiPietro [MSFT] 2017-08-31 16:31:31 UTC
I'm going to set this to needinfo until we can hopefully get a reproduction from someone. If you have been able to cause the crash yourself without the need for HockeyApp and are able to reproduce it in a manner that could help investigation, let us know. I'd also suggest testing with the 2.4.0 prerelease and see if it affects anything as well, should you get the opportunity.
Comment 2 Philipp Sumi 2017-08-31 18:27:34 UTC
No idea what the root cause might be. This is completely random, but overall the most frequent exception I'm seeing in HockeyApp. I'll post back if I learn more.
Comment 3 Paul DiPietro [MSFT] 2017-10-06 17:54:31 UTC
For upkeep I'm going to mark this as not reproducible due to a lack of further reports and assume it isn't an issue as of the 2.4.0 stable release. Please of course feel free to reopen if we can get some more clearly defined steps if it is still occurring as of 2.4.0.