Bug 59098 - Visual Studio for Mac corrupting XCode install
Summary: Visual Studio for Mac corrupting XCode install
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: master
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-29 16:28 UTC by Ben Buttigieg
Modified: 2017-10-06 19:44 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Ben Buttigieg 2017-08-29 16:28:12 UTC
I have a customer complaining about an issue where VS for Mac appears to be corrupting the xCode installation and renders xCode unable to be opened. 
He says he is having to reinstall XCode and replace Xamarin iOS framework a few times a day to keep working! 
My initial thought was that it was a hardware issue. Dodgy SSD or Harddisk. However it's happening on multiple machines including the build server.

The current thinking is it is due to something in the build process as it seems to happen after a successful build. Subsequent builds will then fail as the iOS sdk becomes unavailable and can only be fixed by reinstalling xCode and the iOS Sdk. This obviously is wasting a huge amount of time.
Comment 1 Vincent Dondain [MSFT] 2017-08-29 18:05:15 UTC
Hi,

So I understand the idea but with no actionable data this is going to be hard to track and resolve.

Could we get full build logs, crash reports (if any), test case (to reproduce) and all version information.

To get full build logs just set the log verbosity to diagnostic at the following location: Preferences > Projects > Build.

Also since the current thinking is "it is due to something in the build process as it seems to happen after a successful build" I'm gonna assign that to iOS/msbuild but it could very well be a different part of the product.
Comment 2 Vincent Dondain [MSFT] 2017-10-06 19:44:30 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!