Bug 59097 - [Android] Calling PopAsync via TapGestureRecognizer causes an application crash
Summary: [Android] Calling PopAsync via TapGestureRecognizer causes an application crash
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.4.0
Hardware: PC Windows
: Normal blocker
Target Milestone: 2.4.0
Assignee: Rui Marinho
URL:
: 59130 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-29 16:14 UTC by Paul DiPietro [MSFT]
Modified: 2017-09-12 16:15 UTC (History)
6 users (show)

Tags: navigation, tapgesturerecognizer, popasync, ac, fr
Is this bug a regression?: Yes
Last known good build:


Attachments
Reproduction project (1.47 MB, application/x-zip-compressed)
2017-08-29 16:14 UTC, Paul DiPietro [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul DiPietro [MSFT] 2017-08-29 16:14:28 UTC
Created attachment 24457 [details]
Reproduction project

Regression from the 2.4.0 prerelease thread.

Reproduction comes with 2.3.4 to begin with which has working behavior.

###
Steps
1. Start app
2. Tap the red box view at the top of the view

###
Expected behavior: Navigation pops as expected

###
Actual behavior (on 2.4.0-pre1): Application crash occurs.

Tested on an emulator running Nougat.
Comment 2 Rui Marinho 2017-09-01 15:28:08 UTC
Should be fixed on 2.4.0-pre3
Comment 3 Jimmy [MSFT] 2017-09-03 23:54:38 UTC
*** Bug 59130 has been marked as a duplicate of this bug. ***