Bug 59088 - Making changes in AXML files causes "Metadata error: Could not find part of the path .. "
Summary: Making changes in AXML files causes "Metadata error: Could not find part of t...
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 7.4 (15.3)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2017-08-29 08:12 UTC by danielferenczi
Modified: 2017-10-13 18:27 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description danielferenczi 2017-08-29 08:12:38 UTC
Hello, first bug filed on Bugzilla so not sure I've placed this in the correct category.. 

The bug: 

I'm currently developing an app for both Android and iOS, separated but in the same solution. I've got no Shared project or PC in the solution just one iOS project and one Android project. 

Currently I'm working on the Android app and every time I make a change (edit) a AXML-file the build fails with this error:

Error Metadata - "Error while reading 'C:\Projects\<Project-Path>\<AppName>.iOS\obj\iPhone\Debug\<AppName>.iOS.exe': Could not find a part of the path 'C:\Projects\<Project-Path>\<AppName>.iOS\obj\iPhone\Debug\<AppName>.iOS.exe"

And Visual Studio freezes for 15-25 seconds. When VS eventually responds again I the app builds and deploys again. This problem occurs every time I make a change to a AXML-file. 

Has anybody else encountered this problem before? And if so is there a solution for this annoying bug/problem?


/Daniel
Comment 1 Jon Douglas [MSFT] 2017-08-29 21:23:40 UTC
Thank you for your report!

I'm not quite sure that this bug is related to the Android designer. It seems that you have an error in your iOS project. For us to further investigate, can you please attach a reproduction project and steps to reproduce this issue? For help on writing a bug report, please see our guide on this topic:

https://bugzilla.xamarin.com/page.cgi?id=bug-writing.html

Some of your next steps would be:

1. Including a sample project or steps to reproduce this problem
2. Your Version Information
3. Your expected results and actual results
4. Include a MSBuild diagnostic output log: https://developer.xamarin.com/guides/android/troubleshooting/troubleshooting/#Diagnostic_MSBuild_Output

Thank you!
Comment 2 Jon Douglas [MSFT] 2017-10-13 18:27:13 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!