Bug 59079 - PlayStore APK are not loading fast as release apk via visual studio.
Summary: PlayStore APK are not loading fast as release apk via visual studio.
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: 7.4 (15.3)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2017-08-28 10:14 UTC by Kalpesh Chheda
Modified: 2017-10-04 16:50 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Release build config (86.32 KB, image/jpeg)
2017-08-28 10:14 UTC, Kalpesh Chheda
Details

Description Kalpesh Chheda 2017-08-28 10:14:20 UTC
Created attachment 24442 [details]
Release build config

I am deploying release build with AOT true using visual studio to my android phone is loading very fast(4 Sec).
But same configuration of release build with AOT true I am uploading to playstore and downloading to my same phone is loading slow(11 sec).

Why apk deploy using visual studio is loading fast?
Comment 1 Jon Douglas [MSFT] 2017-08-28 18:47:38 UTC
Thank you for the report!

I believe that you might be running into the following issue:

https://bugzilla.xamarin.com/show_bug.cgi?id=58029

In which we had recently found the cause of this:

https://bugzilla.xamarin.com/show_bug.cgi?id=58029#c16

As for the loading differences, there shouldn't be a difference between the APK you upload to the play store and the apk you install on your device given they were both built using the same configurations. Some items that you might want to consider is using a fresh device (One that has never been used to debug) and install both APKs to time the differences. It's hard to know what the exact case is here as we do not have the APK in question to compare against your Release APK. I would also do a comparison of these two APKs to ensure no settings were changed between the Release -> Store APK. If you have these APKs that we can investigate further with, that would help aid our investigation.

Thank you!
Comment 2 Kalpesh Chheda 2017-08-29 12:59:42 UTC
Tomorrow it was slow. Today I reinstall the apk from store and its loading fast. 6 Seconds compare to 11 seconds without AOT. I will check on more device.
Thanks.
Comment 3 Jon Douglas [MSFT] 2017-10-04 16:50:12 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!

Note You need to log in before you can comment on or make changes to this bug.