Bug 59058 - Tweak Forms previewer "base class not found" error message text
Summary: Tweak Forms previewer "base class not found" error message text
Status: CONFIRMED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms Previewer (show other bugs)
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- enhancement
Target Milestone: 15.6
Assignee: Pierce Boggan [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-08-25 23:13 UTC by Bret Johnson [MSFT]
Modified: 2017-10-05 18:43 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 59058 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
CONFIRMED

Description Bret Johnson [MSFT] 2017-08-25 23:13:53 UTC
Create a new Forms project, show the Previewer, and change the Class attribute of one of the XAML pages to something bogus.

Result:
You see the error message
"The base class associated with this Xaml file could be be found. Please double check the class referenced in the `Class` attribute exists, and that the project has been complied."

Expected:
I spotted a few minor grammar/style/punctuation issues with this message, including that the Class single quotes are backwards. Let's change it to:
"The base class associated with this XAML file could be be found. Please double check that the class referenced in the 'Class' attribute exists and the project has been complied."

Also, let's check the other error messages to see how XAML is capitalized. I saw at least one where it was "xaml". Let's make it consistently "XAML".
Comment 1 David Ortinau [MSFT] 2017-10-05 18:43:15 UTC
Bret is this something you can fix? Where is this error generated from?