Bug 59042 - Specified argument was out of the range of valid values when opening a ListView
Summary: Specified argument was out of the range of valid values when opening a ListView
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.4.0
Hardware: PC Windows
: Normal major
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2017-08-25 14:56 UTC by Luigi Maestrelli
Modified: 2017-12-04 16:24 UTC (History)
6 users (show)

Tags: listview, ac
Is this bug a regression?: Yes
Last known good build:


Attachments
Repo (771.64 KB, application/x-rar)
2017-08-25 14:56 UTC, Luigi Maestrelli
Details
Exception 1 (10.55 KB, text/plain)
2017-08-25 14:57 UTC, Luigi Maestrelli
Details
Exception 2 (57.13 KB, text/plain)
2017-08-25 14:57 UTC, Luigi Maestrelli
Details
Reproduction sample without Prism (418.12 KB, application/x-rar)
2017-08-25 17:17 UTC, Luigi Maestrelli
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Luigi Maestrelli 2017-08-25 14:56:43 UTC
Created attachment 24414 [details]
Repo

Going forward and backward on the page a few times when the second page was an ListView with some images loading from a URI throws "System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values."

I can't always simulate, so I created a repo with the same packages added on my project, specially the MVVW.

Some times I got a different exception, so I will attached both. 
The "Exception 1.txt" is the most common.

I hope that I can give you enough information to find and fix the problem (On Xamarin or in my project), because it is happening almost all the time.

My development workstation:

Windows 10 

Microsoft Visual Studio Professional 2017 
Version 15.3.2
VisualStudio.15.Release/15.3.2+26730.10
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Professional

Mono Debugging for Visual Studio   4.6.8-pre (ec7034f)
Support for debugging Mono processes with Visual Studio.

Xamarin   4.6.0.299 (b63523e27)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.4.0.21 (2851083)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.12.0.20 (80b8487)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

Xamarin Studio 6.3 (build 864) running on MacOS Sierra 10.12.6
Xcode 8.3.3 (8E3004B)
Comment 1 Luigi Maestrelli 2017-08-25 14:57:09 UTC
Created attachment 24415 [details]
Exception 1
Comment 2 Luigi Maestrelli 2017-08-25 14:57:23 UTC
Created attachment 24416 [details]
Exception 2
Comment 3 Paul DiPietro [MSFT] 2017-08-25 16:41:07 UTC
Thanks for getting this together, and I'll set this to confirmed for now. I "fortunately" got the first exception the first time I ran it, and it worked the second time. Would you say that you can still reproduce it without the use of Prism, or is Prism's presence a main factor?
Comment 4 Luigi Maestrelli 2017-08-25 17:17:16 UTC
Created attachment 24423 [details]
Reproduction sample without Prism

Reproduction sample without Prism
Comment 5 Luigi Maestrelli 2017-08-25 17:20:47 UTC
I can reproduce without using Prism.
And I could also reproduced it on Xamarin.Forms.2.3.4.247, so it isn't a 2.4.0 problem.

But would be greate if a fix for this bug went to 2.4.0 because it is crashing on all of your users.

Thank you
Comment 6 Luigi Maestrelli 2017-09-06 14:42:43 UTC
Can we expect this fix to be included in 2.4.0-pre3?
Comment 7 Guilherme Waltricke 2017-09-14 17:21:39 UTC
We are suffering the same problem here, our project deadline is arriving and no solution for this....

please any news about the fix?
Comment 8 Luigi Maestrelli 2017-09-28 12:04:35 UTC
Any news on this?

A new stable release is out (2.4.0.280) and this bug has not been fixed yet.
So, We will have to wait for what, another two months to release a fix on all our apps?
Comment 9 Rui Marinho 2017-10-04 12:05:10 UTC
Can you reproduce on 2.4.0.282 ? I m trying to click  and go back multiple times and i don't get the exception.
Comment 10 Rui Marinho 2017-10-11 13:54:26 UTC
Hi, can you please give us some feedback with 2.4.0.282. Thanks
Comment 11 Paul DiPietro [MSFT] 2017-12-04 16:24:45 UTC
As we have not received a response we will be closing this issue, assuming it no longer occurs. Please reopen this issue with a reproduction project if the issue occurs as of the latest 2.5.0 stable release so that we may investigate further.

Guidelines for creating reproductions are available at:
https://github.com/xamarin/Xamarin.Forms/wiki/Submitting-Bug-Reports