Bug 59039 - bug-18026.exe test times out on armel/armhf
Summary: bug-18026.exe test times out on armel/armhf
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.4
Assignee: Bernhard Urban
URL:
Depends on:
Blocks:
 
Reported: 2017-08-25 12:39 UTC by Alexander Köplinger [MSFT]
Modified: 2017-08-28 06:02 UTC (History)
3 users (show)

See Also:
Tags: clean-ci
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alexander Köplinger [MSFT] 2017-08-25 12:39:27 UTC
Looks like this is because of https://github.com/mono/mono/commit/787faec0048b660f3aede97b5400bef23ba88007

We've seen the test fail since it was merged:
https://jenkins.mono-project.com/job/test-mono-mainline-linux/label=debian-8-armel/ (interestingly, the two places were it didn't fail were run on a tegra64)
https://jenkins.mono-project.com/job/test-mono-mainline-linux/label=debian-8-armhf/
Comment 1 Bernhard Urban 2017-08-25 13:17:50 UTC
FWIW, it failed once on a tegra64 machine too:
https://jenkins.mono-project.com/job/test-mono-mainline-linux/label=debian-8-armel/2898/parsed_console/
Comment 2 Bernhard Urban 2017-08-25 14:37:52 UTC
can confirm that it's caused by 787faec0048b660f3aede97b5400bef23ba88007
Comment 4 Bernhard Urban 2017-08-25 19:20:19 UTC
workaround: https://github.com/mono/mono/pull/5451

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.