Bug 58996 - IsEnabled does not work on a Button
Summary: IsEnabled does not work on a Button
Status: RESOLVED DUPLICATE of bug 43354
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.4
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-24 05:10 UTC by Marek Lipert
Modified: 2017-08-24 17:01 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 43354

Description Marek Lipert 2017-08-24 05:10:29 UTC
Hi There. If I have a button defined like this:

 <Button Text="Stop Scan" 
         IsEnabled="{Binding StopScanningButtonEnabled}"
         Command="{Binding StopScanningCommand}"/>

and the IsEnabled does not work. If I have it like this:

 <Button Text="Stop Scan" 
         Command="{Binding StopScanningCommand}"
         IsEnabled="{Binding StopScanningButtonEnabled}"/>

it does. It seems that the Command parameter is messing something up with IsEnabled.

Thanks for fixing it soon!

It might be related to 23899 and 30097. They are marked as fixed, but the bug is still there.
Comment 1 Paul DiPietro [MSFT] 2017-08-24 17:01:14 UTC
This was already fixed before but was reverted. I will mark this as a duplicate and find out why.

*** This bug has been marked as a duplicate of bug 43354 ***