Bug 58963 - VS2017 15.3.1 Preview 1 failed to update Xamarin.Apple.SDK and Mono Debugging for Visual Studio
Summary: VS2017 15.3.1 Preview 1 failed to update Xamarin.Apple.SDK and Mono Debugging...
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Updater (show other bugs)
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-22 21:41 UTC by LESC
Modified: 2017-10-03 16:39 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin.Apple.SDK update log file (250.97 KB, text/plain)
2017-08-22 21:41 UTC, LESC
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description LESC 2017-08-22 21:41:24 UTC
Created attachment 24355 [details]
Xamarin.Apple.SDK update log file

I'm running Win7-64 on a very stable dual Xeon box with 128GB RAM and RAID hard drives.

I had 5 updates in Extensions and Updates for 'Xamarin Preview' I was able to install 3 of them such as the Xamarin.Android.SDK.

I got a VSIX Installer "Modification failed. Some modifications could not be applied successfully. for the VERY IMPORTANT Xamarin.Apple.SDK.

I'm including the log file.

When I went back into Extensions and Updates, Xamarin.Apple.SDK no longer shows as needing an update?

I was also unable to install the Mono Debugging for Visual Studio update. When it ran in VSIX, I got a dialog 'VSIX Installer' "The selected extensions are already installed to the specified SKU"

So 'Mono Dbugging for Visual Studio' is stuck in my Extensions and Updates for Xamarin Preview. I've tried several times.

Xamarin.Android.SDK shows up as installed and in the 'About Visual Studio' dialog, but Xamarin.Apple.SDK does NOT show up in either the Installed Tools and Extensions or the the 'About Visual Studio' dialog.
Comment 1 Prashant [MSFT] 2017-08-23 06:19:31 UTC
Thanks so much for taking the time to submit this report! I am able to reproduce this issue. Marking this report as CONFIRMED. 

# Version Information

Microsoft Visual Studio Enterprise 2017 Preview
Version 15.3.1 Preview 1.0
VisualStudio.15.Preview/15.3.1-pre.1.0+26730.8
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Enterprise


Xamarin   4.7.0.827 (ddd8750)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.5.0.3 (3e66e8e)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.14.0.4 (c70e3b5)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.
Comment 2 LESC 2017-08-23 16:10:05 UTC
Prashant - glad to help!  How can I get these installed?  Will there be an update in the next few days that will fix it or should I un-install Xamarin and re-install?
Comment 3 Jose Gallardo 2017-09-20 18:42:52 UTC
Hi, 
I'm not sure if you're still facing this issue, but please uninstall and reinstall Xamarin in this case.

Also, please let us know how it goes on.

Thanks
Comment 4 Pierce Boggan [MSFT] 2017-10-03 16:39:58 UTC
Because we have not received a reply to our request for more information in over 14 days, we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information so we can continue looking into this. Thanks!