Bug 58921 - Switching to other Mac server fails to find provisioning.
Summary: Switching to other Mac server fails to find provisioning.
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-08-21 10:04 UTC by Paul Sinnema
Modified: 2017-10-06 18:45 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul Sinnema 2017-08-21 10:04:09 UTC
When I switch to another Mac server the provisioning fails because the Guid in the .csproj file is wrong. I haveo add 2 guids in the .csproj file like shown below and unload the project, comment the wrong one out, remove the comment from the correct one and reload the project.

    <!--<CodesignProvision>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</CodesignProvision>-->
    <CodesignProvision>yyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy</CodesignProvision>
Comment 1 John Miller [MSFT] 2017-08-21 14:11:42 UTC
@Paul,

Could you explain in more detail what you expect here and what specifically you believe the bug to be?

It sounds like your scenario could be related to the issue I filed in Bug #58047.
Comment 2 Paul Sinnema 2017-08-26 16:33:49 UTC
I think it is an architectural mistake to save only 1 provisioning guid in the projectfile. It should be connected to the a mac server. When I am at home I use a different Mac Server then when I am at the customers location. If the guid was connected to the Mac Server then during connection it could find the correct guid.
Comment 3 Paul Sinnema 2017-08-26 16:40:40 UTC
Yes, I believe #58047 is somewhat related. What I ask is somewhat of a missing feature then a bug I guess. The project is compiled correctly once the correct GUID is in place but it's a bit annoying that I have to change the GUID by hand all the time.
Comment 4 Pierce Boggan [MSFT] 2017-10-03 16:46:32 UTC
Information provided. Moving back to NEW state.
Comment 5 Emanuel 2017-10-06 18:45:23 UTC
Hi Paul,
The provisioning name should be saved in the project instead of the GUID. I'm not sure what verison of Xamarin for Visual Studio you're using, but this issue is already fixed on our latest 15.4 preview.

Thanks for reporting!