Bug 58882 - "Refresh" context menu item in solution pane does not fully refresh
Summary: "Refresh" context menu item in solution pane does not fully refresh
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: .NET Core support (show other bugs)
Version: 7.1 (d15-3)
Hardware: PC Mac OS
: Normal normal
Target Milestone: 15.6
Assignee: Matt Ward
URL:
Depends on:
Blocks:
 
Reported: 2017-08-18 15:14 UTC by Aaron Bockover [MSFT]
Modified: 2018-01-11 11:44 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Aaron Bockover [MSFT] 2017-08-18 15:14:52 UTC
1. Open an .NET Core project that implicitly builds its <Compile> nodes (<Compile Include="**\*.cs"/>).

2. Perform a rename _outside_ of VSM (e.g. a git mv) of one of the files in an expanded directory.

3. (notice that the folder does not update automatically, which is a completely separate issue)

4. Right click on the folder in VSM that contains the renamed file and choose "Refresh"

5. Notice that the old file name is still in the tree, but is now red, because it no longer exists

   -> expected: this node should have been removed

6. Notice that the new file name does not appear at all

   -> expected: a new node should be added for the new/renamed file
Comment 1 Matt Ward 2018-01-08 22:13:58 UTC
There is a dotnet-file-watcher feature branch which will support this by automatically handling renames done outside of VS Mac. It is currently targeted for 15.6 but has not been approved by QA yet.
Comment 2 Lluis Sanchez 2018-01-11 11:44:22 UTC
Fixed in 15.6