Bug 58372 - Monodevelop crashes while debugging with SIGSEGV
Summary: Monodevelop crashes while debugging with SIGSEGV
Status: RESOLVED DUPLICATE of bug 42029
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: 6.3 (15.1)
Hardware: PC Linux
: --- normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2017-07-25 15:27 UTC by Thomas Klose
Modified: 2017-08-02 15:00 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Crash log (176.35 KB, text/plain)
2017-07-25 15:27 UTC, Thomas Klose
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42029

Description Thomas Klose 2017-07-25 15:27:58 UTC
Created attachment 23795 [details]
Crash log

While examining Dictionaries within the debugger, Monodevelop crashes occasionally with a SIGSEGV (see attached logfile).

Steps to (occasionally) reproduce:

* start MD in debugger with an active breakpoint
* examine a rather large (1000 entries) dictionaries
* GUI closes when object view is expanded to see single elements

We are running Monodevelop 6.3 (build 864) with Mono runtime 5.0.1 on Debian/Stretch. Mono has been self-compiled. Thereby the configure-switch --with-large-heap=yes has been defined.
Comment 1 iain 2017-08-02 15:00:47 UTC

*** This bug has been marked as a duplicate of bug 42029 ***