Bug 58251 - When looking for valid signing certificates, print out each invalid certificate and state why it's not valid
Summary: When looking for valid signing certificates, print out each invalid certifica...
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: master
Hardware: PC Mac OS
: --- enhancement
Target Milestone: 15.6
Assignee: Vincent Dondain [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-07-19 14:34 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2017-12-12 19:34 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2017-07-19 14:34:07 UTC
When diagnosing why code signing fails, such as:

> error : No valid iOS code signing keys found in keychain. You need to request a codesigning certificate from https://developer.apple.com.

it would be helpful to know why the existing certificates on the machine (if any) aren't applicable.

Such as:

"The certificate C is not valid because its prefix P does not match any of the app's prefixes P1, P2, ..."
"The certificate C is not valid because it expired on October 21st, 2015"
Comment 1 Rolf Bjarne Kvinge [MSFT] 2017-10-04 11:07:21 UTC
Partially implemented: https://github.com/xamarin/Xamarin.MacDev/pull/16
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-10-09 05:25:03 UTC
Partially fixed in https://github.com/xamarin/xamarin-macios/pull/2865
Comment 3 Jeffrey Stedfast 2017-10-24 17:06:42 UTC
What else needs to be done on this?
Comment 5 Vincent Dondain [MSFT] 2017-12-05 21:11:26 UTC
PR https://github.com/xamarin/xamarin-macios/pull/3085 to fix what Rolf suggested in https://bugzilla.xamarin.com/show_bug.cgi?id=58251#c4

Note: if we find other occurrences let's fix them but I don't think it's necessary to have a bug open against this (especially one opened against the next release milestone), otherwise we'll just have a bug saying: "add more logging info" and it'll stay open forever (;
Comment 6 Vincent Dondain [MSFT] 2017-12-12 19:34:35 UTC
https://bugzilla.xamarin.com/show_bug.cgi?id=58251#c4 fixed in https://github.com/xamarin/xamarin-macios/commit/808c67017da7fc6d9f14f1f3a9d6b70bc1aa61c8

Closing this bug since all reported issues have been fixed.