Bug 58154 - Previewer wants me to connect to Mac but VS is already connected
Summary: Previewer wants me to connect to Mac but VS is already connected
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms Previewer (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Pierce Boggan [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-07-14 08:46 UTC by René
Modified: 2017-10-20 20:59 UTC (History)
3 users (show)

Tags: xamextfollowed
Is this bug a regression?: ---
Last known good build:


Attachments
Screenie1 (691.19 KB, image/png)
2017-07-14 08:46 UTC, René
Details
Screenie2 (622.57 KB, image/png)
2017-07-14 08:46 UTC, René
Details
Logs (34.30 KB, application/zip)
2017-07-17 09:29 UTC, René
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description René 2017-07-14 08:46:03 UTC
Created attachment 23554 [details]
Screenie1

My VS2017 is connected to the Mac and I can run iOS apps on the remote sim.
If I open the previewer it tells me I have to connect to a Mac build host.
It shows me all the Macs and the correct one is already connected (and the connect button is disabled).

See screenshots.



Xamarin Version: 4.5.0.486
Comment 1 René 2017-07-14 08:46:18 UTC
Created attachment 23555 [details]
Screenie2
Comment 2 Alan McGovern 2017-07-14 09:30:38 UTC
Can you attach the logs from that session? Help -> Zip Xamarin Logs (or somewhere in there).
Comment 3 René 2017-07-17 09:29:22 UTC
Created attachment 23590 [details]
Logs
Comment 4 René 2017-07-17 09:30:43 UTC
I attached zipped logs of the last 7 days. I reported the bug shortly after the problem.

Meanwhile, the previewer is working. I rebooted the Windows machine and the Mac. So it was a temporary issue but maybe still wort investigating.
Comment 6 Pierce Boggan [MSFT] 2017-10-03 16:36:23 UTC
I'm unable to reproduce this issue using Visual Studio 2017 version 15.4 Preview 4. 

Rene, are you still able to reproduce this issue on the latest builds?
Comment 7 René 2017-10-04 10:24:02 UTC
Seems to work, yes.
Comment 8 Pierce Boggan [MSFT] 2017-10-20 20:59:12 UTC
Awesome, marking as RESOLVED -> NOT REPRODUCIBLE. Please feel free to re-open if you hit this again. :)

Thanks again for filing this issue, Rene!