Bug 58132 - [llvm/bitcode] Crash in mono_class_has_failure (class.c:9850)
Summary: [llvm/bitcode] Crash in mono_class_has_failure (class.c:9850)
Status: RESOLVED UPSTREAM
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler (show other bugs)
Version: XI 10.14 (d15-4)
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.7
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2017-07-13 09:50 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2018-03-09 14:28 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: It worked this spring (maybe 15.1, not sure)


Attachments
crash report (52.50 KB, text/plain)
2017-07-13 09:50 UTC, Rolf Bjarne Kvinge [MSFT]
Details
Smaller test case (90.17 KB, application/zip)
2017-07-14 15:16 UTC, Rolf Bjarne Kvinge [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Rolf Bjarne Kvinge [MSFT] 2017-07-13 09:50:53 UTC
Created attachment 23525 [details]
crash report

Repro:

* Build xamarin-macios/d15-4 locally
* Open tests/monotouch-test-watchos.sln
* Select monotouch-test-watchos-app as the startup project.
* Select the Release|iPhone configuration and a watch as the device.
* Run
* Tap "Run tests" when the app shows up (10-15 minutes later) on the watch.

Result:

* App crashes. See attached crash report

Application output: https://gist.github.com/rolfbjarne/3b2d882ca54c6cc46b83260ed394126c
lldb session: https://gist.github.com/rolfbjarne/68183fa6f45ab99122aeb7b6232dca78
Comment 1 Zoltan Varga 2017-07-13 11:43:36 UTC
Is this a regression ?
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-07-13 11:46:15 UTC
Yes, monotouchtest ran successfully earlier this year (around February I think).
Comment 3 Rolf Bjarne Kvinge [MSFT] 2017-07-14 15:16:40 UTC
Created attachment 23568 [details]
Smaller test case

I'm attaching a smaller test case.

Run the monotouch-test-watchos-app project on a watchOS device in release mode.

This is the output in the application output:

DownloadDataAsync a
DownloadDataAsync v
DownloadDataAsync f
DownloadDataAsync ii
Xamarin.Hosting: Process '425' exited.

The last part is because the process crashed.

The executed code is in monotouch-test-watchos-extension/InterfaceController.cs:

		public void DownloadDataAsync ()
		{
			Console.WriteLine ("DownloadDataAsync a");

			NSTimer.CreateScheduledTimer (0.01, async (v) => {
				Console.WriteLine ("DownloadDataAsync f");
				var tcs = new System.Threading.Tasks.TaskCompletionSource<bool> ();
				Console.WriteLine ("DownloadDataAsync ii");
				await tcs.Task;
				Console.WriteLine ("DownloadDataAsync j");
			});

			Console.WriteLine ("DownloadDataAsync v");
		}

but it's not only related to this code (I've added this code to a different watchOS project, and it works fine).
Comment 4 Chris Hardy [MSFT] 2017-09-11 15:35:45 UTC
Moving out to 15.5
Comment 5 Chris Hardy [MSFT] 2017-09-28 17:57:52 UTC
Moving out to 15.6 too as this is a late Mono change to bring in if this was fixed
Comment 6 Rolf Bjarne Kvinge [MSFT] 2018-03-09 14:20:17 UTC
I can still reproduce this with d15-7.
Comment 7 Rolf Bjarne Kvinge [MSFT] 2018-03-09 14:28:24 UTC
Moved to the mono repo: https://github.com/mono/mono/issues/7535