This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 5806 - Cannot stop on breakpoints in MFA application using MD master 65ce49cee0
: Cannot stop on breakpoints in MFA application using MD master 65ce49cee0
Status: VERIFIED WORKSFORME
Product: Android
Classification: Xamarin
Component: Xamarin Studio Addin
: 4.2.x
: PC Mac OS
: --- blocker
: ---
Assigned To: Bugzilla
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-06-21 14:11 EDT by PJ
Modified: 2013-05-29 03:22 EDT (History)
4 users (show)

See Also:
Tags:
Test Case URL:
External Submit: ---


Attachments

Description PJ 2012-06-21 14:11:04 EDT
Steps:
Start new MFA template app
Set some breakpoints
Debug

Expected:
Debugger should stop on breakpoints

Actual:
Debugger does not stop at all

Behavior:
http://screencast.com/t/9hLbG8ab

Logcat:
https://gist.github.com/2967463

Using
MD Master (65ce49cee0d12d11381c1beb5f000944bbc400d7)
MFA stable 4.2.3


Debugger does stop on breakpoints with MD 3.0.3.2 and MFA 4.2.3, but there are
other issues with that combination that I will file separately.
Comment 1 PJ 2012-06-21 14:26:56 EDT
I can stop on breakpoints in a console app
Comment 2 PJ 2012-06-21 14:29:07 EDT
Behavior on MD 3.0.3.2 stable:

http://screencast.com/t/UEvmMxZisBs0


The lines where the breakpoints are not hit are also bugs and I will be filing
those separately.
Comment 3 Peter Collins 2013-05-21 11:47:32 EDT
Unable to reproduce on our current stables, resolving.
Comment 4 Mikhail 2013-05-27 03:47:37 EDT
Still not debugging portable library.
Comment 5 PJ 2013-05-28 11:04:04 EDT
Mikhail: true, but this was just an issue with *all* breakpoints from a long
while back.
Comment 6 Mikhail 2013-05-29 03:22:43 EDT
PJ, thanks for the reply. I have found workaround in 8209.

Note You need to log in before you can comment on or make changes to this bug.