Bug 57804 - Slightly incorrect error message when trying to use ref/out parameters with BindAs attributes
Summary: Slightly incorrect error message when trying to use ref/out parameters with B...
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Alex Soto [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-06-27 19:00 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2017-11-13 20:29 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2017-06-27 19:00:17 UTC
Test case:

	[Export ("setCGAffineTransformValueRefNonNullable:")]
	void SetCGAffineTransformValueRefNonNullable ([BindAs (typeof (CGAffineTransform))] ref NSValue value);

results in:

	BTOUCH: error BI1048: bgen: Unsupported type CATransform3D decorated with [BindAs]

which is slightly misleading, because "CATransform3D" is a supported type (it's "CATransform3D&", the ref variant, which isn't).
Comment 1 Alex Soto [MSFT] 2017-11-11 23:42:02 UTC
PR: https://github.com/xamarin/xamarin-macios/pull/2997
Comment 2 Alex Soto [MSFT] 2017-11-13 20:29:55 UTC
Fixed in xamarin-macios/master @ https://github.com/xamarin/xamarin-macios/commit/b197eab50ec13f88dd5afa680c45828059a7cbf9