Bug 5755 - Can't increase trampolines
Summary: Can't increase trampolines
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime (show other bugs)
Version: 5.3.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Sebastien Pouliot
URL:
: 5800 5960 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-19 13:26 UTC by Stuart Carnie
Modified: 2016-04-25 09:00 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Stuart Carnie 2012-06-19 13:26:50 UTC
If I include -aot "nimt-trampolines=512", device build will not run, with following error in log:

Failed to load AOT module 'mscorlib' while running in aot-only mode: not compiled with --aot=full.

If I omit that line, compiles and runs, but crashes as there are not enough trampoline slots
Comment 1 Stuart Carnie 2012-06-19 13:34:53 UTC
Okay, figured it out; must put comma (,) at end as follows: 

-aot "nimt-trampolines=512,"

OR command-line will be generated incorrectly (not 512full, rather than 512,full):

…bin/arm-darwin-mono-sgen --debug --aot=mtriple=armv7-darwin,nimt-trampolines=512full,static,…

Not sure if this is a MonoDevelop or 5.3.3 issues, as I updated both at the same time.
Comment 2 Sebastien Pouliot 2012-06-19 14:21:19 UTC
There were some changes in 5.3.x in the options handling. I'll review this.
Thanks for the test case!
Comment 3 Sebastien Pouliot 2012-06-19 15:15:13 UTC
Fixed in master: ebd8787c092eaa0e51c2f7d5e57a7daa4a49c0ed

Your workaround is correct (adding the comma) and will still work (you won't have to remove it) on future MT releases. Thanks again.

QA: from b5222bb8c9e53718df06fbdd54e697b6bab47ab4 the bots will run such a case for each build
Comment 4 Sebastien Pouliot 2012-06-21 09:46:11 UTC
*** Bug 5800 has been marked as a duplicate of this bug. ***
Comment 5 Rolf Bjarne Kvinge [MSFT] 2012-07-03 17:24:23 UTC
*** Bug 5960 has been marked as a duplicate of this bug. ***