Bug 57512 - key input error after "vi" execution
Summary: key input error after "vi" execution
Status: RESOLVED NORESPONSE
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-15 02:01 UTC by s2quake
Modified: 2018-03-13 11:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description s2quake 2017-06-15 02:01:33 UTC
using System;
using System.Diagnostics;

namespace ConsoleApp1
{
    class MainClass
    {
        public static void Main(string[] args)
        {
            var s = Console.CursorTop; // this line raise a key bug
            var startInfo = new ProcessStartInfo();

            startInfo.UseShellExecute = false;
            startInfo.FileName = @"vi";
            startInfo.Arguments = "";

            using (var process = Process.Start(startInfo))
            {
                process.WaitForExit();
            }

            // press left key after vi exit
            ConsoleKeyInfo keyInfo;
            while ((keyInfo = Console.ReadKey(true)).Key != ConsoleKey.Q)
            {
                //keyInfo.Key is not ConsoleKey.LeftArrow
                Console.Write(keyInfo.KeyChar);
            }
        }
    }
}
Comment 1 Marek Safar 2017-09-12 13:54:38 UTC
Thank you for your report!

I’m unable to reproduce this issue locally using the information you provided. In order to investigate the issue further can you please attach a reproduction project and steps to reproduce this issue? For help on writing a bug report, please see our guide on this topic:

https://bugzilla.xamarin.com/page.cgi?id=bug-writing.html

Some of your next steps would be:

1. Including a sample project or steps to reproduce this problem
2. Your Version Information
3. Your expected results and actual results

Thank you!
Comment 2 Marek Safar 2018-03-13 11:07:31 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!