Bug 57488 - Debugger crashes when inspecting variable in a unit test
Summary: Debugger crashes when inspecting variable in a unit test
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: 5.2 (2017-04)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
: 57133 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-14 15:42 UTC by Ben Buttigieg
Modified: 2017-12-30 03:40 UTC (History)
5 users (show)

See Also:
Tags: xamexttriage
Is this bug a regression?: ---
Last known good build:


Attachments
Example solution demonstrating Debugger crash (7.25 KB, application/zip)
2017-06-14 19:32 UTC, Ben Buttigieg
Details

Description Ben Buttigieg 2017-06-14 15:42:54 UTC
Using Visual Studio for Mac I have been unable to Debug a failing nunit test as the debugger keeps crashing.

When I hit a breakpoint and attempt to inspect an object retrieved from a service locator, the debugger says evaluating then instantly crashes the session.

Works fine in Visual Studio 2017. I am able to evalate and inpect the returned object without issue.

Will attach code to repro issue.
Comment 1 Ben Buttigieg 2017-06-14 19:32:52 UTC
Created attachment 22894 [details]
Example solution demonstrating Debugger crash

Run the Unit in the attached project through debugger.
Place breakpoint at line 14 or 21 and inspect the alertService.

Expected Result:
Able to inpect value of variable

Actual Results:
Debugger crashes.
Comment 2 David Karlaš 2017-06-15 14:39:52 UTC
I can reproduce this, but based on crash looks like runtime problem.
Comment 3 Ben Buttigieg 2017-06-15 16:14:09 UTC
Note the crash does not occur in Visual Studio 2017
Comment 4 Zoltan Varga 2017-06-20 18:17:58 UTC
https://github.com/mono/mono/pull/5076
Comment 5 Ludovic Henry 2017-07-06 23:02:32 UTC
Hello,

@Ben, could you verify if your issue is fixed? If not, what do you need to verify it?

Thanks,
Ludovic
Comment 6 Aleksey Kliger 2017-12-30 03:40:50 UTC
*** Bug 57133 has been marked as a duplicate of this bug. ***

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.