Bug 57415 - Debugger losing break points within Task.Run
Summary: Debugger losing break points within Task.Run
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: 7.1 (d15-3)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 15.6
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2017-06-12 22:39 UTC by Paul Johnson
Modified: 2017-10-04 12:13 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Paul Johnson 2017-06-12 22:39:37 UTC
https://www.screencast.com/t/xzY1K4pWFnng

Break points set within a Task.Run are being removed / ignored. They are hit outside of the Task.Run

=== Visual Studio Community 2017 for Mac (Preview) ===

Version 7.1 Preview (7.1 build 583)
Installation UUID: 933163e9-dca5-472b-b2ed-29d7aab111ab
Runtime:
	Mono 5.2.0.104 (2017-04/4a0006f) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 502000104

=== NuGet ===

Version: 4.0.0.2323

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
SDK: /usr/local/share/dotnet/sdk/1.0.0-preview2-1-003177/Sdks
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.4
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 8.3.2 (12175)
Build 8E3004b

=== Xamarin.Mac ===

Version: 3.5.0.126 (Visual Studio Community)

=== Xamarin.Android ===

Version: 7.3.1.2 (Visual Studio Community)
Android SDK: /Users/PFJ/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)
		7.0   (API level 24)
		7.1   (API level 25)

SDK Tools Version: 26.0.2
SDK Platform Tools Version: 25.0.6
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin.iOS ===

Version: 10.11.0.126 (Visual Studio Community)
Hash: 7571635e
Branch: master
Build date: 2017-05-09 16:04:54-0400

=== Xamarin Inspector ===

Version: 1.3.0-alpha2
Hash: fa030e0
Branch: master
Build date: Thu, 01 Jun 2017 20:55:26 GMT
Client compatibility: 1

=== Build Information ===

Release ID: 701000583
Git revision: 445a7f09feca58babb966e0c66a6b299d0bd450c
Build date: 2017-05-12 16:05:38-04
Xamarin addins: f9b72ca5f6ca5d9476d8f58353ada2afd56c549b
Build lane: monodevelop-lion-d15-3-preview

=== Operating System ===

Mac OS X 10.12.5
Darwin 16.6.0 Darwin Kernel Version 16.6.0
    Fri Apr 14 16:21:16 PDT 2017
    root:xnu-3789.60.24~6/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Redth's Addins 1.0.6
Comment 1 Mike Krüger 2017-06-13 06:10:46 UTC
Can't reproduce this behavior in ios/android or console projects.
Is the solution you're working in accessible to us ?
Comment 2 Paul Johnson 2017-06-13 08:27:58 UTC
I can add you to the GitHub repo or upload the project to dropbox - whichever is easier for you.
Comment 3 David Karlaš 2017-07-06 07:18:18 UTC
First try updating Xamarin.Android, Xamarin.iOS and Xamarin.Forms to latest stable version, there are known issues with older versions, if that doesn't solve issue either add https://github.com/DavidKarlas to repository or send download link to david.karlas@microsoft.com
Comment 4 David Karlaš 2017-10-04 12:13:24 UTC
I'm pretty sure this was problem with outdated "Xamarin.Android, Xamarin.iOS or Xamarin.Forms" and portable .pdb. Hence closing.