Bug 57128 - ContextActions on ListView Permanently Destroyed Forever
Summary: ContextActions on ListView Permanently Destroyed Forever
Status: RESOLVED DUPLICATE of bug 55588
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.5
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-03 04:00 UTC by krispenner
Modified: 2017-06-08 16:41 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduceable Solution (150.12 KB, application/x-zip-compressed)
2017-06-03 04:00 UTC, krispenner
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 55588

Description krispenner 2017-06-03 04:00:47 UTC
Created attachment 22668 [details]
Reproduceable Solution

Navigate to a child page, display ContextActions on a ListView, close the child page (navigating back to the parent page) while ContextActions are still being shown.  Go to any other ListView on any other page and no ContextActions will ever be shown again.  I'm guessing there is only a single instance of the ContextActions menu which is shared across all ListViews, and if its still attached to the page when that page is destroyed then it gets destroyed along with it - just a guess.

Very simple to reproduce, see attached solution.

Tested Hardware & Development Versions:
  iPhone 6 with iOS 10.3.1
  Xamarin.Forms 2.3.4.247
  Windows 10 Enterprise
  Microsoft Visual Studio Community 2017: Version 15.2 (26430.12) Release
  Microsoft .NET Framework: Version 4.6.01586
  Xamarin: 4.5.0.476 (1be4f0c)
  Xamarin.iOS and Xamarin.Mac SDK: 10.10.0.35 (4cffddf)

Code Setup:
  ** SEE ATTACHED SOLUTION **
  1) create a NavigationPage with the root page containing a button to open a second page
  2) on second page display a ListView with some items in it and some ContextActions
  3) run the app on iOS

Steps to Reproduce:
  1) run app: main page is shown
  2) click Show List button: list page with ListView is shown
  3) swipe list item: ContextActions are shown
  4) (do not close ContextActions) click the Back navigation link to close the list page
  5) root page is shown again
  6) click Show List button: list page with ListView is shown
  7) swipe list item...
EXPECTED:
  8) ContextActions are shown
ACTUAL:
  8) nothing happens, no ContextActions are ever shown again on any other ListView anywhere in the App ever again.
Comment 1 Paul DiPietro [MSFT] 2017-06-04 17:31:43 UTC

*** This bug has been marked as a duplicate of bug 55588 ***
Comment 2 krispenner 2017-06-06 06:13:57 UTC
Hi,

Please correct me if I am mistaken, but I don't believe this has been fixed and is noted in the duplicated bug 55588 above:
https://bugzilla.xamarin.com/show_bug.cgi?id=55588

According to that bug, this is suppose to be fixed in Pull Request 885:
https://github.com/xamarin/Xamarin.Forms/pull/885

And according to that pull request it was released in version 2.3.5.239-pre3:
https://github.com/xamarin/Xamarin.Forms/releases/tag/beta-2.3.5-pre3

I have downloaded that "fixed" version 2.3.5.239-pre3 from nuget into my project, built and run my app, I still experience the above issue/bug.

Please let me know if I am missing a step and how I can then properly test that this has fixed my bug; otherwise I ask you please re-open my bug.

Thanks!
kp