Bug 57094 - Improve BI1014 - include name of unsupported field and valid types
Summary: Improve BI1014 - include name of unsupported field and valid types
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: master
Hardware: PC Mac OS
: Normal enhancement
Target Milestone: 15.6
Assignee: Alex Soto [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-06-02 10:24 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2017-11-21 18:25 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2017-06-02 10:24:25 UTC
Test code:

[Static]
partial interface Constants
{
	[Field ("SomeField", "__Internal")]
	byte[] SomeField { get; }
}

shows:

> error BI1014: bgen: Unsupported type for Fields: byte[]

which is correct, but we could improve to include the name of the field ('SomeField') and list the valid types:

> error BI1014: been: The field 'Constants.SomeField' has an unsupported type ('byte[]'). Valid types are: ...
Comment 2 Alex Soto [MSFT] 2017-11-13 21:49:20 UTC
PR: https://github.com/xamarin/xamarin-macios/pull/3001

I did not add all the supported types to the message string but updated our documentation to reflect the supported types by FieldAttribute[1] since we support several of them :).

[1]: https://github.com/xamarin/xamarin-macios/pull/3001/files#diff-4c7ba4890ac45e2bb1d4bdb45c6d17b8R1383
Comment 3 Alex Soto [MSFT] 2017-11-14 14:55:57 UTC
Fixed in xamarin-macios/master @ https://github.com/xamarin/xamarin-macios/commit/21a56a5f27ad8cacea1cac53df30031aa1fd444c