Bug 57069 - WaitHandle.SignalAndWait is broke
Summary: WaitHandle.SignalAndWait is broke
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: io-layer (show other bugs)
Version: 5.0 (2017-02)
Hardware: PC Mac OS
: Normal major
Target Milestone: ---
Assignee: Ludovic Henry
URL:
Depends on:
Blocks:
 
Reported: 2017-06-01 19:20 UTC by Jonathan Chambers
Modified: 2017-06-05 19:18 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Jonathan Chambers 2017-06-01 19:20:34 UTC
Run the follow test case. It hangs in Mono 5.0+. This is a regression from Mono 4.8

using System;
using System.Threading;

internal class Program
{
    public static void Main (string[] args)
    {
        using (var eventToSignal = new AutoResetEvent (false))
        using (var eventToWait = new AutoResetEvent (false))
        {
            eventToWait.Set ();

            var res1 = WaitHandle.SignalAndWait (eventToSignal, eventToWait);
            Console.WriteLine ("res1: " + res1);

            var res2 = eventToSignal.WaitOne ();
            Console.WriteLine ("res2: " + res2);
        }
    }
}
Comment 1 Jonathan Chambers 2017-06-01 19:28:04 UTC
This runs fine on Mono with Windows, so this looks like a w32 layer issue.
Comment 2 Ludovic Henry 2017-06-05 19:18:33 UTC
This is fixed with https://github.com/mono/mono/pull/4973

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.