Bug 57023 - Missing Android.Wearable.CapabilityApi namespace
Summary: Missing Android.Wearable.CapabilityApi namespace
Status: RESOLVED ANSWERED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 8.0 (15.4)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2017-05-31 21:10 UTC by dj_technohead
Modified: 2017-10-13 17:43 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description dj_technohead 2017-05-31 21:10:33 UTC
Hi,
   I've added the Xamarin.Android.Wear nuget package to the project, but I'm not able to reference anything in the CompatibleApi namespace. Is this missing from the package?

thanks,
Dennis
Comment 1 dj_technohead 2017-06-01 18:39:03 UTC
I have Android SDK Platform 25, Android SDK Tools 25.2.5 and the Android Support Respository installed.

Dennis
Comment 2 Jon Douglas [MSFT] 2017-06-23 19:52:45 UTC
Thank you for taking the time to submit the bug. We are unable to reproduce this issue. Please attach a reproduction to the bug by starting with a clean Xamarin.Android project and adding just the code necessary to demonstrate the issue.

It is highly recommended to follow the following guide for a more complete bug description.

https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/howto-file-bug/

If you can get us a project that demonstrates this issue, we can help investigate what you're running into. I am marking this bug as NEEDINFO for the time being as there are not enough details as to how we can reproduce this issue.
Comment 3 dj_technohead 2017-06-26 19:56:44 UTC
I believe the CompatibilityApi is new to Android Wear 2.0, which (please correct me if I'm wrong) I don't believe Xamarin currently supports.

thanks,
Dennis
Comment 4 Jon Douglas [MSFT] 2017-08-21 21:04:18 UTC
Hi Dennis,

Can you let us know which APIs you are trying to access? Perhaps the Java equivalent will help us pinpoint your problem. You can also link to documentation or a tutorial you're trying to follow. I've listed the wear packages below(And support library):

https://developer.android.com/reference/android/support/wear/widget/package-summary.html

https://developer.android.com/reference/android/support/wear/widget/drawer/package-summary.html

https://developer.android.com/reference/android/support/wearable/classes.html

Perhaps you are referring to CapabilityApi?

https://developers.google.com/android/reference/com/google/android/gms/wearable/CapabilityApi

We bind against the .jar google provides in the extras of the SDK:

Android\sdk\extras\google\m2repository\com\google\android\wearable\wearable\{VERSION}

https://www.nuget.org/packages/Xamarin.Android.Wear/

You may want to try the beta package: https://www.nuget.org/packages/Xamarin.Android.Wear/2.0.3-beta1

Thanks!
Comment 5 dj_technohead 2017-08-22 01:10:52 UTC
Sorry, for some reason I kept switching "Compatibility" for "Capability", yes I was referring to the CapabilityApi (https://developers.google.com/android/reference/com/google/android/gms/wearable/CapabilityApi)

Is this only supported in the beta nuget package?  

Dennis
Comment 6 Jon Douglas [MSFT] 2017-10-13 17:43:44 UTC
This API would be found rather in the Android.Gms.Wearable namespace which is the Google Play Services - Wearable package:

https://www.nuget.org/packages/Xamarin.GooglePlayServices.Wearable/