Bug 56917 - VS2017 Build failed PortableSharedProject.dll is locked
Summary: VS2017 Build failed PortableSharedProject.dll is locked
Status: RESOLVED DUPLICATE of bug 56275
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General (show other bugs)
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-28 00:08 UTC by Daniel Little
Modified: 2017-05-31 22:45 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56275

Description Daniel Little 2017-05-28 00:08:56 UTC
VS2017 (15.2)
Installed VS then Modified install to install Xamarin
Using Xamarin Forms

First build always works, always fails with every subsequent build (devenv.exe is locking the file).

Could not copy "obj\Debug\PortableSharedProject.dll" to "bin\Debug\PortableSharedProject.dll". Exceeded retry count of 10. Failed.
Comment 1 Daniel Little 2017-05-28 03:05:02 UTC
Manually running a clean if the issue occurs does appear to work. But is less than ideal.
Comment 2 Michael Warnes 2017-05-29 21:50:41 UTC
Agreed, I have this problem to
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-31 22:45:26 UTC

*** This bug has been marked as a duplicate of bug 56275 ***