Bug 56839 - Debugging session aborts due to "Could not load file or assembly 'Mono.Posix...' or one of its dependencies" even when Mono.Posix.dll is present in Common7\IDE\Extensions\Xamarin\Xamarin
Summary: Debugging session aborts due to "Could not load file or assembly 'Mono.Posix....
Status: RESOLVED DUPLICATE of bug 56787
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-25 15:07 UTC by anton.duzenko@gmail.com
Modified: 2017-05-30 17:16 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot (80.70 KB, image/png)
2017-05-25 15:07 UTC, anton.duzenko@gmail.com
Details
debug output (167.56 KB, text/plain)
2017-05-25 15:08 UTC, anton.duzenko@gmail.com
Details
version info (2.77 KB, text/plain)
2017-05-25 15:10 UTC, anton.duzenko@gmail.com
Details

Description anton.duzenko@gmail.com 2017-05-25 15:07:46 UTC
Created attachment 22460 [details]
Screenshot

This started happening today with no apparent reason.
Simply start the app under debugger and as soon the app tries to show the master/detail view the debugger crashes.
I am using vs2015 and latest version of Xamarin,
Same computer, tablet, and cable work when I run the app from inside the OSX VM (VS2017 for Mac).
Comment 1 anton.duzenko@gmail.com 2017-05-25 15:08:24 UTC
Created attachment 22461 [details]
debug output
Comment 2 Brendan Zagaeski (Xamarin Support) 2017-05-25 15:09:53 UTC
See Bug 56787, Comment 15 for a temporary workaround to copy the missing file into place by hand.  Thanks!

*** This bug has been marked as a duplicate of bug 56275 ***
Comment 3 Brendan Zagaeski (Xamarin Support) 2017-05-25 15:10:20 UTC

*** This bug has been marked as a duplicate of bug 56787 ***
Comment 4 anton.duzenko@gmail.com 2017-05-25 15:10:27 UTC
Created attachment 22462 [details]
version info
Comment 5 anton.duzenko@gmail.com 2017-05-25 15:13:30 UTC
Where can I download 4.4.0.34?
Comment 6 Brendan Zagaeski (Xamarin Support) 2017-05-25 15:16:40 UTC
https://dl.xamarin.com/XamarinforVisualStudio/Windows/Xamarin.VisualStudio_4.4.0.34.msi


In case it might be helpful somewhere down the line, you can look up other older versions in general from [1], following the steps under "Download links" on [2].

[1] https://store.xamarin.com/account/my/subscription/downloads
[2] https://kb.xamarin.com/customer/portal/articles/1699777-older-downloads
Comment 7 anton.duzenko@gmail.com 2017-05-25 15:37:07 UTC
I replaced the file from that link but it still crashes for me
Comment 8 Brendan Zagaeski (Xamarin Support) 2017-05-25 16:47:50 UTC
Just for a first very quick check before we dig into more detailed logs for the assembly loading process (with fuslogvw), you can collect and paste back the file date and size from a `dir` command in a cmd.exe command prompt.

dir "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Xamarin\Xamarin\Mono.Posix.dll"



### Example output

> 03/30/2017  11:02 AM           187,912 Mono.Posix.dll
Comment 9 anton.duzenko@gmail.com 2017-05-25 18:55:31 UTC
19.01.2017  12:59           187,912 Mono.Posix.dll
Comment 10 Brendan Zagaeski (Xamarin Support) 2017-05-26 23:02:52 UTC
## Next data gathering steps to try


1. Set up Visual Studio to the state just before you hit the error (that is, just before "the app tries to show the master/detail view").


2. Create a directory to store the assembly load log files, for example:

C:\Temp\FusionLogs


3. Start a Developer Command Prompt with administrative privileges.


4. Run `fuslogvw` in the command prompt.


5. In the Assembly Binding Log Viewer that opens, click the "Settings" button.


6. Set:

- Log bind failures to disk

- Enable custom log path

- Custom log path:
C:\Temp\FusionLogs\

(Be sure to include the trailing \ backslash at the end of the path.)


7. Click OK.


8. Switch back to Visual Studio and proceed to hit the error.


9. Switch back to the Assembly Binding Log Viewer.


10. Look for the line where the "Description" column starts with "Mono.Posix" and double-click that line to open it in a browser window.


11. Save that file to a convenient location (or make note of the original path) and attach it back on the bug report.


12. Switch back to the Assembly Binding Log Viewer and change the "Settings" back to:

- Log disabled

- Custom log path: [empty]




Thanks in advance!
Comment 11 anton.duzenko@gmail.com 2017-05-29 13:26:08 UTC
476 fixed it for me (after quick test)
Comment 12 Joaquin Jares 2017-05-30 17:16:23 UTC
This is a duplicate of 56787.

*** This bug has been marked as a duplicate of bug 56787 ***

Note You need to log in before you can comment on or make changes to this bug.