Bug 56800 - Could not copy "obj\Debug\dllName.dll" to "bin\Debug\dllName.dll". Exceeded retry count of 10. Failed.
Summary: Could not copy "obj\Debug\dllName.dll" to "bin\Debug\dllName.dll". Exceeded r...
Status: RESOLVED DUPLICATE of bug 56275
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-24 13:34 UTC by Wally McClure
Modified: 2017-05-24 15:16 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56275

Description Wally McClure 2017-05-24 13:34:31 UTC
Here is my scenario:
1.  One instance of VS 2017 loaded with an XF application.
2.  Second instance of VS 2017 loaded with my back end web services for the application.  No code shared between this instance and the first instance.
3.  Trying to compile in the first instance.  Eventually, I get an error message about a dll being locked. 
4.  The only way to clear the locks is to close both instances and reload.

I realize that BugID 31423 states that the locked .dll files has been fixed, however, this is happening in this scenario.

Thanks.
Comment 1 Jimmy [MSFT] 2017-05-24 15:16:32 UTC
This is a duplicate of bug 56275 and should be fixed in the 15.2.2 release: https://releases.xamarin.com/stable-release-15-2-2/

*** This bug has been marked as a duplicate of bug 56275 ***