Bug 56795 - DataTriggers do not work on UWP in RELEASE mode
Summary: DataTriggers do not work on UWP in RELEASE mode
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.5
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
: 57060 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-24 10:20 UTC by FieldstrikeMobile
Modified: 2017-07-04 05:52 UTC (History)
7 users (show)

Tags: ac uwp releasemode .netnative datatrigger
Is this bug a regression?: ---
Last known good build:


Attachments
repo project (324.91 KB, application/x-zip-compressed)
2017-05-24 10:20 UTC, FieldstrikeMobile
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description FieldstrikeMobile 2017-05-24 10:20:44 UTC
Created attachment 22416 [details]
repo project

I have uploaded a sample application.

Steps to reproduce:
1. open app on UWP run in Debug and see trigger works fine
2. open app on UWP run in release see trigger doesnt work.
Comment 1 Jimmy [MSFT] 2017-05-25 22:12:20 UTC
I can confirm that DataTriggers are not working on UWP when "Compile with .NET Native tool chain" is enabled, which is the default in Release mode.


### Version Test
2.3.5-pre3  BAD
2.3.4.247   BAD
Comment 2 FieldstrikeMobile 2017-05-26 07:35:57 UTC
@Jimmy I found a solution to this was to do the following:

 Xamarin.Forms.Forms.Init(e, new[] { typeof(Xamarin.Forms.Xaml.Extensions).GetTypeInfo().Assembly });

I know about the whole UWP renderer issue but I would have never expected to pass one of Xamarins own libraries into that method. Probably worth documenting somewhere?
Comment 3 Matthew Richardson 2017-06-02 19:39:40 UTC
We confirm this same issue and the above workaround is valid.
This is a critical issue which needs a hot fix on top of the current XF 2.3.4 release.
Comment 4 Stephane Delcroix 2017-06-06 11:09:57 UTC
*** Bug 57060 has been marked as a duplicate of this bug. ***
Comment 6 Rui Marinho 2017-06-28 22:00:44 UTC
Should be fixed on 2.3.5-pre6
Comment 7 Neha Kharbade 2017-07-03 12:07:39 UTC
Hi Rui,

I have verified this bug with steps provided with version 2.3.5.256-pre6. In release mode data trigger launched but there are still few differences the way it worked on debug mode. 

Please check following screen cast and kindly confirm the expected result. So that I can processed.

Thanks in advance

Screencast : https://www.screencast.com/t/E6TKZU8Dkck7


https://gist.github.com/nehaKh/c8359a37d891f57ba254e91754312ab5