Bug 5676 - Setting timeout on BasicHttpBinding does not affect a client's timeout
Summary: Setting timeout on BasicHttpBinding does not affect a client's timeout
Status: RESOLVED DUPLICATE of bug 19697
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: 5.3.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-15 16:06 UTC by Blake Jones
Modified: 2016-02-15 16:19 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
My test project for setting the timeouts on a WCF client (1.33 MB, application/zip)
2012-06-15 16:06 UTC, Blake Jones
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 19697

Description Blake Jones 2012-06-15 16:06:51 UTC
Created attachment 2071 [details]
My test project for setting the timeouts on a WCF client

When I set the receive timeout for the client in my application it does not affect my client's receive timeout, instead it uses the default 1 minute timeout. I have been able to change it using the InnerChannel member of the client but I was hoping for more control over configuring the client.

I've attached a sample iphone application where when you click the button it will display the time it took to hit the service. You will need to specify a service in order to test it.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2016-02-15 16:19:52 UTC

*** This bug has been marked as a duplicate of bug 19697 ***