Bug 56758 - MT2001 - instruction cannot be null
Summary: MT2001 - instruction cannot be null
Status: RESOLVED DUPLICATE of bug 56296
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: XI 10.10 (d15-2)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-23 13:33 UTC by p.k
Modified: 2017-05-23 14:05 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Complete build log (217.16 KB, text/rtf)
2017-05-23 13:33 UTC, p.k
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56296

Description p.k 2017-05-23 13:33:41 UTC
Created attachment 22390 [details]
Complete build log

With the latest stable release I am encountering the error 

> MTOUCH : error MT2001: Could not link assemblies.
>	Method: `System.Void Bachmann.CustomViews.BadgeImage::.cctor()`
>	Assembly: `Bachmann, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null`
> Reason: Value cannot be null.
> Parameter name: instruction

for builds, when the linker is active (SDK only). I've tried several different build configurations, but nothing helped.When I'm linking everything the error is

> MTOUCH : error MT2091: Inliner failed processing `System.Void Bachmann.CustomViews.BadgeImage::.cctor()`.
>	Value cannot be null.
>	Parameter name: instruction

The logs are attaches. Unfortunately I cannot share the source code, since it is a project for a customer. If I can provide any further information I will happily do so.
Comment 1 Alex Soto [MSFT] 2017-05-23 13:55:17 UTC
This is a dupe of bug 56296

*** This bug has been marked as a duplicate of bug 56296 ***
Comment 2 p.k 2017-05-23 14:05:03 UTC
Alex, thank you very much, the workaround in the other bug report worked for me.