Bug 56562 - Listview scrolling getting stuck while I am using relative layout in viewcell (In Android)
Summary: Listview scrolling getting stuck while I am using relative layout in viewcell...
Status: RESOLVED DUPLICATE of bug 56240
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on: 56240
Blocks:
  Show dependency tree
 
Reported: 2017-05-17 12:43 UTC by Abdul Mujeeb Khan
Modified: 2017-06-23 19:20 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Project (1.29 KB, application/zip)
2017-05-17 12:47 UTC, Abdul Mujeeb Khan
Details
RelativeLayout Perf Issue Sample Project (111.75 KB, application/x-zip-compressed)
2017-05-25 02:18 UTC, Lee Richardson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56240

Description Abdul Mujeeb Khan 2017-05-17 12:43:00 UTC
Listview scrolling getting stuck while I am using relative layout in viewcell. Earlier it was working fine, but I think because of updating nuget packages or Xamarin studio, this issue arised. (In Android)

Now while scrolling very first time in this case, Scrolling get stuck after some time it scrolls smooth.

Alternatively If i use Stack layout instead of relative layout, listview scrolls smooth, But i need relative layout.

    Xamarin.forms : 2.3.4.247

    Xamarin Studio Community
    Version 6.3 (build 864)
    Installation UUID: f9acdb29-2b13-4556-9887-824b8e4e0693
    Runtime:
    Mono 5.0.0.100 (2017-02/9667aa6) (64-bit)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 500000100

    Xamarin.iOS
    Version: 10.10.0.33 (Xamarin Studio Community)
    Hash: 3e5ac5ff
    Branch: d15-2
    Build date: 2017-05-05 18:11:38-0400

    Xamarin.Android
    Version: 7.3.0.13 (Xamarin Studio Community)
    Android SDK: /Users/abdul/Andoid-SDK-s/android-sdk-macosx
    Supported Android versions:
    4.4 (API level 19)
    5.0 (API level 21)
    6.0 (API level 23)
    7.0 (API level 24)
    7.1 (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.4
SDK Build Tools Version: 24.0.3

    Java SDK: /usr
    java version "1.8.0_111"
    Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
Comment 1 Abdul Mujeeb Khan 2017-05-17 12:47:34 UTC
Created attachment 22229 [details]
Project
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-17 18:48:01 UTC
## Note to the Xamarin team

This sounds potentially related to Bug 56240?  Perhaps once candidate builds are available that resolve Bug 56240, it would be good to have the reporter of this Bug 56562 check if those builds resolve this issue as well.
Comment 3 Lee Richardson 2017-05-25 02:13:50 UTC
I've noticed the same issue.  The RelativeLayout performance in a custom ViewCell of a ListView is virtually unusable on Android, but fine in iOS.

I already started writing up a ticket before I found this one, so I'm including my sample project as a 2nd data point.
Comment 4 Lee Richardson 2017-05-25 02:18:21 UTC
Created attachment 22439 [details]
RelativeLayout Perf Issue Sample Project

In XfRelativeLayoutIssue\MainPage.cs it uses a RelativeLayout in a custom ViewCell of a ListView.  When you run this on Android (API 22 anyway) the performance is virtually unusable.
Comment 5 Jon Douglas [MSFT] 2017-06-23 19:20:39 UTC
I've tested both 

https://bugzilla.xamarin.com/attachment.cgi?id=22229

and

https://bugzilla.xamarin.com/attachment.cgi?id=22439

And it seems the performance is fine. I believe based on the fix in https://bugzilla.xamarin.com/show_bug.cgi?id=56562#c2 that has resolved this issue. Thus I am marking this bug as a DUPLICATE of https://bugzilla.xamarin.com/show_bug.cgi?id=56240

Version Information:

Microsoft Visual Studio Enterprise 2017 
Version 15.2 (26430.13) Release
VisualStudio.15.Release/15.2.0+26430.13
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Enterprise

Xamarin   4.5.0.486 (fec6f88)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.3.1.2 (9dbc4c5)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.10.0.37 (ad35de4)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

*** This bug has been marked as a duplicate of bug 56240 ***