Bug 56548 - Performance Degradation When Parsing Data
Summary: Performance Degradation When Parsing Data
Status: RESOLVED DUPLICATE of bug 56240
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 7.3 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on: 56240
Blocks:
  Show dependency tree
 
Reported: 2017-05-17 09:25 UTC by laemmchen
Modified: 2017-05-26 16:18 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (95.89 KB, application/x-zip-compressed)
2017-05-17 09:25 UTC, laemmchen
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56240

Description laemmchen 2017-05-17 09:25:24 UTC
Created attachment 22221 [details]
Sample Project

We updated to the latest Xamarin in Visual Studio and noticed a huge
delay on all our Android Applications when starting our Apps.

Our Apps usually load some config data upon startup stored in JSOn format.
Accessing some sample Data went from around 140ms to 8955ms with the latest Xamarin update.

I added a small project to demonstrate this.
Comment 1 laemmchen 2017-05-17 09:34:14 UTC
This occurs on both VS2015 and 2017.
The huge delay happens on the very first of the Application.
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-17 18:48:29 UTC
## Note to the Xamarin team

This sounds potentially related to Bug 56240?  Perhaps once candidate builds are available that resolve Bug 56240, it would be good to have the reporter of this Bug 56562 check if those builds resolve this issue as well.
Comment 3 laemmchen 2017-05-26 07:53:13 UTC
The latest patch for Visual Studio 2015 on the Update Channel for Bug 56240 also fixes this problem.
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-26 16:18:10 UTC
Excellent.  Thanks very much for the check.  I'll mark this bug as a duplicate for bookkeeping.

*** This bug has been marked as a duplicate of bug 56240 ***