Bug 56545 - Xamarin Forms new files templates missing in NetStandard project
Summary: Xamarin Forms new files templates missing in NetStandard project
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Templates (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: 15.5
Assignee: Bugzilla
URL:
: 57903 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-17 08:29 UTC by Francesco Marsoni
Modified: 2017-10-31 10:56 UTC (History)
6 users (show)

Tags: VS2017I
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Francesco Marsoni 2017-05-17 08:29:47 UTC
# Steps to reproduce
Create a Xamarin.Forms project. Change target framework to NetStandard 1.4 and fix adding in project.json
  "frameworks": {
    "netstandard1.4": {
      "imports": [
        "portable-net45+win8+wpa81+wp8"
      ]
    }
  }

# Expected behavior
Add new file -> forms

# Actual behavior
Add new file -> no forms section

# Supplemental info (logs, images, videos)


# Test environment (full version information)
Comment 1 Pierce Boggan [MSFT] 2017-06-15 15:41:03 UTC
Marking this as CONFIRMED. Xamarin.Forms recently added support for .NET Standard in it's 2.3.5-pre builds, so this will soon be a supported scenario that the tooling needs to support.

At a glance, it looks like we need to update the `<AppliesTo>` elements for .NET Standard, but not finding documentation on this element for netstandard projects.
Comment 2 Pierce Boggan [MSFT] 2017-07-03 15:13:14 UTC
*** Bug 57903 has been marked as a duplicate of this bug. ***