Bug 56521 - Xamarin Android AXML inflation is now UNUSABLY slow as of 4.5.0.443 - there may be more problems than just this
Summary: Xamarin Android AXML inflation is now UNUSABLY slow as of 4.5.0.443 - there m...
Status: RESOLVED DUPLICATE of bug 56240
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 7.3 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on: 56240
Blocks:
  Show dependency tree
 
Reported: 2017-05-16 18:55 UTC by Craig Johnson
Modified: 2017-08-21 20:30 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56240

Description Craig Johnson 2017-05-16 18:55:22 UTC
Something is seriously borked with the latest version of Xamarin.Android as opposed to previous versions. After updating to Visual Studio 15.2 (Xamarin.Android 7.3.0.13), our Android apps across the board are unusably slow, particularly when there are complex UI layouts.

When debugging and setting breakpoints on methods such as .Inflate, we notice unacceptable delays. Screen rendering which used to take 1-2 seconds now take 30-75 seconds. At times, the screen will go black while it attempts to build the view.

Returning to Visual Studio 15.1 and the corresponding Xamarin toolchain is difficult now given the forward-only nature of Visual Studio deployment.

We will try the 15.3 preview to see if this is a known issue but in the meantime this has brought all Android development to a halt.

Xamarin.iOS is unaffected and we have seen no adverse issues.
Comment 1 Craig Johnson 2017-05-16 19:23:48 UTC
Same issues in the current 15.3 preview (Xamarin.Android is the same version - 7.3.0.13).

Please provide a fix ASAP, more than 70 apps are affected by this issue.
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-16 23:56:37 UTC
## Note to the Xamarin team for preliminary cross-referencing

This might be another variation on the underlying issue from Bug 56240.
Comment 3 goneale 2017-05-22 01:05:40 UTC
Yes 100% agree with Craig, we have noticed the exact same behaviour exhibiting across our Android apps and believe it appears to be with layout inflation. The load time in rendering Activities and Fragments now have gone from 250ms~ to >4s in some cases. We cannot push out updates until we can resolve this.

The latest build of Xamarin in VS 2017 is offering to us Android 7.3.0.13, even though the Xamarin releases page appears to show there is a newer release out 7.3.1.1. I have tried to get this version of Android even with VS 2017 preview to no avail. So I'm not sure if this problem has been identified and fixed.

Thanks team.
Comment 4 goneale 2017-05-22 01:23:05 UTC
Reading through Bug 56240, it does appear they are correlated and glad to hear a fix is underway for Windows.
Comment 5 Jon Douglas [MSFT] 2017-06-26 16:05:30 UTC
(In reply to Craig Johnson from comment #0)
> Something is seriously borked with the latest version of Xamarin.Android as
> opposed to previous versions. After updating to Visual Studio 15.2
> (Xamarin.Android 7.3.0.13), our Android apps across the board are unusably
> slow, particularly when there are complex UI layouts.
> 
> When debugging and setting breakpoints on methods such as .Inflate, we
> notice unacceptable delays. Screen rendering which used to take 1-2 seconds
> now take 30-75 seconds. At times, the screen will go black while it attempts
> to build the view.
> 
> Returning to Visual Studio 15.1 and the corresponding Xamarin toolchain is
> difficult now given the forward-only nature of Visual Studio deployment.
> 
> We will try the 15.3 preview to see if this is a known issue but in the
> meantime this has brought all Android development to a halt.
> 
> Xamarin.iOS is unaffected and we have seen no adverse issues.

I am marking this bug as NEEDINFO as I am requesting the bug reporter to confirm that the behavior has been resolved as per the fix included in https://bugzilla.xamarin.com/show_bug.cgi?id=56240

You should be able to get a 15.2.2 build containing a fix from the Visual Studio 2017 Installer stable channel of updates or through the Xamarin updater in VS 2015.

I will check on this issue in the next couple days and if there's no confirmation, I will go ahead and mark this bug as a DUPLICATE of the known performance issue listed above.
Comment 6 Jon Douglas [MSFT] 2017-08-21 20:30:37 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!

*** This bug has been marked as a duplicate of bug 56240 ***